• \[SOLVED\] Installation error


    I’m trying to install on VirtualBox and I receive this error after choosing my partitioning:

    Traceback (most recent call last):
    File “/usr/share/cnchi/src/pacman/pac.py”, line 116, in do_refresh
    db.update(force=False)
    alpm.error: unable to update database, pm_errno 0 (unexpected error)
    : do_refresh in /usr/share/cnchi/src/pacman/pac.py:111

    And then the installer quits. I did try the CLI installer as an alternative but after it runs I get a message that it has been successfully updated and to restart the installer but I am never able to restart the installer.

    any ideas?

    Cheers,
    B

  • I’m trying to install on VirtualBox and I receive this error after choosing my partitioning:

    Traceback (most recent call last):
    File “/usr/share/cnchi/src/pacman/pac.py”, line 116, in do_refresh
    db.update(force=False)
    alpm.error: unable to update database, pm_errno 0 (unexpected error)
    : do_refresh in /usr/share/cnchi/src/pacman/pac.py:111

    And then the installer quits. I did try the CLI installer as an alternative but after it runs I get a message that it has been successfully updated and to restart the installer but I am never able to restart the installer.

    any ideas?

    Cheers,
    B

  • Hi there. Sorry to hear you are having issues with installation. The error looks like it could be a problem with an Arch mirror that is out of sync. Try updating the mirrorlist file by commenting out the first mirror and uncommenting one of the others with:

    su -c 'nano /etc/pacman.d/mirrorlist'
    

    Then refresh the databases:

    su -c 'pacman -Sy'
    

    If that does not fix it, post the logs from /tmp/cnchi.log & /var/log/pacman.log. Oh, and about the CLI installer. You can launch it after it updates with terminal command ‘/arch/setup’

    Regards,

  • Thanks for the info … not sure if changing the mirrors was what worked since I discovered I was also having a proxy issue (needed to configure for http_proxy and HTTP_PROXY) and the GUI installer ran like a charm.

  • Hi,

    I have the same problem: trying to install Antergos in a virtualbox but in the network where I am there’s a proxy and the GUI installer can’t access the internet to download packages.

    Please, can you tell me how can I set the proxy to let the GUI installer to work?

    Thanks in advance!

  • Not sure that it will work in this situation but you can change (or set up) your proxy settings in [b:3tktrvxb]Settings -> Network -> Network Proxy[/b:3tktrvxb].

    Arvis Lācis (@arvislacis)

  • Not sure that it will work in this situation but you can change (or set up) your proxy settings in Settings -> Network -> Network Proxy.

    That didn’t work but I solved in another way.

    After you start Antergos in a Virtual-Box:

    [*:34x6q37q]Close the Cnchi GUI
    [/*Ⓜ34x6q37q]
    [*:34x6q37q]Open a terminal and switch in super user mode:

    \# su
    

    No password is required.
    [/*Ⓜ34x6q37q]
    [*:34x6q37q]Manually set the proxy:

    \# export http\_proxy="myproxy:8080"  
    \# export https\_proxy="myproxy:8080"  
    \# export ftp\_proxy="myproxy:8080"  
    \# export HTTP\_PROXY="myproxy:8080"  
    \# export HTTPS\_PROXY="myproxy:8080"  
    \# export FTP\_PROXY="myproxy:8080"
    

    [/*Ⓜ34x6q37q]
    [*:34x6q37q]Launch Cnchi GUI installer from the terminal:

    \# cnchi
    

    Now the GUI installer is able to download packages!

Posts 7Views 5114
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.