• Cinnamon update freeze computer


    I just made Cinnamon update and have big problem. Icons from the panel are missing, the system is too slow, and I have to choose between Cinnamon and Cinnamon software rendering at login screen. This i pacman log:

    [2015-06-02 17:29] [ALPM] transaction started
    [2015-06-02 17:29] [ALPM] installed libgsystem (2015.1-1)
    [2015-06-02 17:29] [ALPM] upgraded cinnamon-desktop (2.4.2-1 -> 2.6.4-1)
    [2015-06-02 17:29] [ALPM] upgraded cinnamon-settings-daemon (2.4.3-1 -> 2.6.2-1)
    [2015-06-02 17:29] [ALPM] upgraded cinnamon-session (2.4.3-2 -> 2.6.2-1)
    [2015-06-02 17:29] [ALPM] upgraded cinnamon-translations (2.4.4-1 -> 2.6.1-1)
    [2015-06-02 17:29] [ALPM] upgraded cjs (2.4.2-1 -> 2.6.0-1)
    [2015-06-02 17:29] [ALPM] upgraded muffin (2.4.5-2 -> 2.6.1-1)
    [2015-06-02 17:30] [ALPM] upgraded cinnamon-menus (2.4.1-1 -> 2.6.0-1)
    [2015-06-02 17:30] [ALPM] upgraded cinnamon-control-center (2.4.2-3 -> 2.6.0-1)
    [2015-06-02 17:30] [ALPM] upgraded cinnamon-screensaver (2.4.2-1 -> 2.6.2-1)
    [2015-06-02 17:30] [ALPM] upgraded nemo (2.4.5-1 -> 2.6.5-1)
    [2015-06-02 17:30] [ALPM] upgraded cinnamon (2.4.8-1 -> 2.6.6-1)
    [2015-06-02 17:30] [ALPM] transaction completed
    

    How to rollback pacman update? Does anyone have a similar problem?

  • I have similar problem …
    after cinnamon update

    my menu is closed … smaller

    I click it does not open

  • @Dario-Giusiano said:…

    I click it does not open

    are you sure to use the stock, standard, native cinnamon’s menu applet ([email protected])? i was using Configurable Menu applet. after update it has stopped working (doesn’t open) here as well. while the stock Menu applet works without a problem.

    there’s another strange thing after today’s update to 2.6.6. seems like Restart option (Power Off, Restart, Log Out…) has completely disappeared from all menus, applets, etc. there’s no Restart option anymore, nowhere :confused:

    i added the hand-made Restart option to the menu, but it doesn’t seem to be a normal solution.

  • I agree, same problems here…l :confused:

    Antergos Gnome 64 Bits.

  • A system restart is required after installing the update. Let me know if you have rebooted and still experience issues. Thanks.

  • confirm that - a system restart is required.

    the update process has finished with the nasty popup window “cinnamon session can’t continue, do you want to reload it? Yes No” (or smth similar). without answering neither Yes nor No, i’ve killed the X server with Ctrl+Alt+BkSp. it turned me back to warm and familiar login screen. from there, i’ve simply rebooted the system. after reboot the new cinnamon 2.6.6 works nicely here.

    the solution to restore traditional Power Off dialog functionality (with Shutdown and Restart buttons) is briefly and clearly described in El Che’s post (worked like a charm for me) and by Clem himself on Segfault.

    the native cinnamon’s Menu applet continues to work without a problem here.

    the Configurable Menu applet, broken after update, is repaired by uninstalling it from cinnamon and installing it back again. after reinstalling it works normally.

  • Updated yesterday to cinnamon 2.6.6 via pacman and tried the suggested solutions in EL Che’s post or Clem’s solution but these did not fix the issue of misssing options in the shutdown dialog.
    When i try to shutdown/restart the system via the panel menu, the dialog, that shows up only the “Cancel” Button.
    Selection_002.png
    Applets like the Shutdown Applet by shelly did not work either until i applied a solution i found on the net to change the applet.js file by changing every line like
    Util.spawnCommandLine(“dbus-send --system --print-reply --system --dest=org.freedesktop.ConsoleKit /org/freedesktop/ConsoleKit/Manager org.freedesktop.ConsoleKit.Manager.Stop”);
    to
    Util.spawnCommandLine(“systemctl poweroff”);
    I assume that in the last update, cinnamon changed something internally, so that cinnamon itself cannot find the shutdown options etc. so that the menu shutdown dialog isn’t populated anymore.

    Any suggestions where to start looking for debugging this? It seems to be a Arch+Cinn:

    My System is:
    Lenovo Thinkpad T440p
    Antergos x64
    Linux version 4.0.4-2-ARCH
    Cinnamon 2.6.6

    EDIT:
    Update to cinnamon 2.6.7 seems to have fixed the issue.

cinnamon2.6.4-11 Posts 7Views 1820
Log in to reply