• Is there a way to change the system`s language?


    I accidently set the language on the setup to portuguese, and I want to change it to english, is there a way I can do that without reinstalling the whole OS?

  • what DE are you using?
    In gnome go to “Preferences/Settings” and then Language/Region. Set your language preferences, some packages will be updated if it is not previously installed

  • @karasu I’m using this topic that wasn’t originally mine , because my problem is almost the opposite . I needed make the instalation ( Antergos with KDE4 ) in English , because it’s not possible , yet , to make in Portuguese ; so , after that , changing at Configurations to Brasil , pt-BR , etc. , many things continues at English ; the system still was in US.utf8 .Then I followed these instructions: "https://wiki.archlinux.org/index.php/Locale " but the better result is : en_US.utf8
    pt_BR.utf8 And is still most part in English. How can I fix this ?

  • @Rodrigo-Virmond

    Have you installed the kde-l10n-pt_br package?

  • @karasu Yes , like I wrote : "changing at Configurations' to Brasil , pt-BR , etc. " I read that the update version of Firefox don't have pt-BR , yet ( I changed with "about:config" and nothing ) , but many other things stay in English ,too . I read the other topic aboutto change language ', I followed the tips , but I changed "a half ": before it was en_US.utf8 en_US.utf8 and I changed to en_US.utf8 pt_BR.utf8 .
    I don’t know why these lines above changed the look ! I’m not screaming , I swear .

  • @Rodrigo-Virmond

    Hahaha… don’t worry. For firefox you also have to install firefox-i18n-pt-br

    What else stays in English?

  • I tried a new look over the situation , because there are some things that remains in English always : I made a fresh installation in Spanish . Interesting fact this - in Spanish , installs , and in Portuguese , not .:no_mouth:
    So I installed pt-BR things (firefox-i18n-pt-br too ) , System Configurations is "Brasil " pt-BR , Firefox too , restart … Then I I had three languages at the system , and at Firefox . I deleted the kde-10n spanish (or something that), any difference . I installed Pale Moon directly and it’s ok , so it remains . And now I have Gestor de Paquetes , Gestor de Actualizaciones ,Bleach, VLC , at the Dolphin I rename the archives but a file called Descargas always back …

  • Install package xdg-user-dirs (if you don’t have it already) and run xdg-user-dirs-update with your user (not root!).

    Tell me if it helps.

  • I’m not in my PC . I’ll back soon.

  • Hello everyone, i have a similar issue… when installing i choose english as language, but italy as region (what i wanted is to have the system in english but all formats, like dates, in the italian format), the result is the whole system is in italian… after installing i tried changing the language from “language/region” under “settings” but the only language i see listed is italian.

    After reading https://wiki.archlinux.org/index.php/Locale i tried generating the en_US.utf8 locale and updating /etc/locale.conf but the only thing that changed is that now under language/region i only see English (which is selected, and italian is not even there anymore :( ) but is still all in italian.
    Maby there is some language package i have to install for gnome? (i searched but i could not find any)

    thanks

  • Thanks for the answer @just, the thing is i have already done all that: uncomment en_US.UTF-8 UTF-8 from /etc/locale.gen, run locale-gen… and English actually appeared in Language/Region panel, i choosed English and logged out/in (even restarted the laptop) but gnome interface and console messages are still in italian (actually a don’t see any changes at all).
    After that i tried editing manually /etc/locale.conf but it is correctly set to en_US.UTF-8, i also tried with localectl set-locale LANG=en_US.UTF-8 with no effect.

    Here is a strange thing: even if in gnome region panel language is set to English, and locale.conf has LANG=en_US.UTF-8, if i run locale command from the console i get LANG=it_IT.UTF-8. My guess is, there is some other configuration file overwriting the default locale, maybe some gnome specific file? i checked if i have ~/.config/locale.conf file in my home dir but there is none…

    any idea of what other config file can be overwriting the configuration?

    ps: the Formats are ok, in gnome panel is set to italian and running locale from the console shows the correct LC_* variables

  • @mdread It’s still not clear for me what are you trying to do - too many words, too many things mixed together. Sorry.

    Anyway,

    • Under normal circumstances there’s no need to edit /etc/locale.conf by hand

    • Check that there’s no ~/.config/locale.conf file in your home dir. It overrides the system-wide locale set by /etc/locale.conf

    • Take a look at your /etc/X11/xorg.conf.d/10-keyboard.conf file. Again, do not edit it by hand. It should have the keyboard you’re trying to set

  • @just i’ll try to summarize what i need and what is the current state.

    My goal is easy: keyboard and formats set to Italy, Gnome interface in english.

    the current state of the installation is:

    • Keyboard and formats both correctly set to italy (ok!)

    • Gnome interface is still in italian, even if the Region/Language panel says it is in english (see image below)

    Schermata da 2015-07-14 23-24-38.png

    some extra information:

    • ~/.config/locale.conf is not present in my home dir
    • /etc/locale.conf says the locale is en_US.UTF-8 but running locale from console says locale is it_IT.UTF-8. This is why i think there is something else overwriting the system-wide locale configuration
    • /etc/X11/xorg.conf.d/10-keyboard.conf has the XkbLayout option set to “it” (which is ok)

    hope it’s clearer now :)

  • Problem solved!
    don’t know why but /etc/environment was setting LANG to it_IT.UTF-8, and it was overwriting the configuration in /etc/locale.conf, i removed the line and gnome interface is finally in english :D

  • @mdread Meno male :satisfied: . Environment variables were the next step I was going to talk about. Nice to know you have solved the problem yourself, thus avoiding a long posts interchange about them. Bravissimo :thumbsup: !

language15 Posts 17Views 10322
Log in to reply