• Light Locker Settings


    I installed the Gnome 64 bit build from 5/26/2015. I have everything running perfectly but cannot solve one issue. I cannot get a screen saver to work. I have changed the Light Locker settings and it will blank the screen when I change the delay time ( if I leave the Light Locker window open). If enter Apply and re-open Light Locker it does not save my settings and returns to the blank screen never setting. . Does anybody else have this issue or have a suggestion on how to fix it?

  • After fixing my locking screen issues, i just now tested this and it works for me. Not that me telling you it works for me helps you at all. But, at least you know it works for some people. I noticed that there are several power, screen saver settings scattered all over the place. I’m not sure if they all use the same config files or not, but you could just check and maybe one of these settings is overriding your light locker settings. Or maybe a permission issue on the file that stores these settings.
    Confusing, but i found the following places that all appear to change the same setting. Maybe make sure they are all adjusted to the same setting?

    1. Light locker settings.
    2. Gnome settings>Power>Blank screen
    3. Gnome settings>Privacy>Screen Lock
    • I am not an expert, take whatever i say and research on your own.
  • @Mark-Rife
    UPDATE to my above post. After further tweaking, I also just had the same experience as you. After the screen blanked/locked and i logged back int the settings reverted. I’m currently playing with different combinations from the areas i described in my post above. So for me it did keep the settings, until the settings were activated. I’m guessing it’s just one setting has higher priority over the the others and is reverting it back.

  • After further research, it looks like this is a known issue. It appears the only answer at this time is to switch to GDM. I am wondering if any of the developers can confirm there is not a fix for this before I switch.

  • Hi all,

    I use sddm (with plasma5), so I can’t be of much help here. On the other hand maybe @lots.0.logs can shred some light in this.

    Cheers!

  • @Mark-Rife
    My google-fu found the same info. But it looks like this problem is an older one, so i’m surprised it is still happening. I hope a developer can chime in also. I read that replacing light locker with gnome screen saver can also be a solution. Might be worth a try before completely switching to gdm. I should have never read your comment and lived in ignorance (or at least until i discovered it on my own). Now after tweaking and trying to “fix” it, I don’t think i’m happy with my settings now. Please follow up with your solution. I’ve some how lost my screen dimming when inactive while figuring out this problem. Good luck.
    I can post logs for anyone reading this.

  • @SirWeazel Sorry good Sir Weazel! I switched to GDM and everything is functional. Not as slick looking, but functional.

  • If a developer should happen to read this (and there is not a fix in the works) I would suggest placing a sticky on the Gnome category advising users that screen saving/locking will not be functional for Gnome users without installing GDM (instructions on how to install GDM and replace Light DM would be a good idea).

  • I apologize for the delayed response. Last I checked, screen locking was working. I’ll take another look as soon as I have some time.For the time being, I recommend switching to GDM if screen locking is important to your workflow.

    Cheers!

  • Alternitatively (this is what I am doing myself) you can install the “Turn off display” extension from the gnome tweak tool. In this way you can keep using the nice-looking lightDM instead of the ugly grey GDM and turn on/off your screen whenever YOU want it to…:thumbsup:
    https://extensions.gnome.org/extension/897/turn-off-display/

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I saw this post and am also having an issue with the screen lock. In my case, using the dm-tools lock function results in a white screen with nothing happening at all anymore. The only way to get out of the white screen is hitting CTRL-ALT-F1, which takes me back to my session - no log in required. Same issue with the switch-to-greeter function. I also installed light locker to see if that would fix the issue, but when I try to use light locker to lock the screen nothing happens. No screen change, no logout. Nada.

  • In order to have a working screensaver and locker, use xscreensaver with light-locker.
    Light locker settings => DISABLE (remove the autostart files it creates)
    Gnome settings>Power>Blank screen => OFF
    Gnome settings>Privacy>Screen Lock => ON
    Run: systemctl enable xscreensaver
    Now use xscreensaver-demo to configure settings.

    If you need to change the screensaver time on LightDM (while waiting for login for example),
    Edit /etc/lightdm/lightdm.conf and change the following line:
    display-setup-script=/usr/bin/sh -c "/usr/bin/xset s 300 300 && /usr/bin/xset dpms 300 300 300"
    300 seconds = 5 minutes, change accordingly, the first two are for the screensaver, the last 3 for turning off the monitor.

  • @Mark-Rife
    I ended up switching to GDM also and not looking back. To other people following this thread. If you are not worried about multiple desktop environments and are using gnome, then this might be the solution for you.

    I used the instructions from the antergos wiki:
    http://antergos.com/wiki/desktops/installing-display-managers/
    BEFORE SWITCHING DISPLAY MANAGER, PLEASE UNDERSTAND WHAT YOUR ARE DOING AND RESEARCH ACCORDINGLY.

    sudo pacman -Rcns lightdm
    sudo pacman -S gdm
    sudo systemctl -f enable gdm
    

    @vsilvar
    Thanks for your solution also.

  • The first line (sudo pacman -Rcns lightdm) removes lightdm. If I may suggest, removing lightdm is not really necessary, you can just install gdm, and enable it with systemctl. After all LIGHTdm is very …light and it makes no harm to keep it, just in case something goes wrong.
    And by the way, if you don’t like the grey GDM background, it can be easily changed, check this:
    http://forum.antergos.com/topic/1773/why-lightdm-with-antergos-gnome/9

    Intel NUC D54250WYK, 16 Gb RAM, 1 Tb SSD
    Multi -boot (no MS-Win &no UEFI) Legacy MBR with GPT

  • @ant77
    Thanks for the info. I almost went that route. I was just going to install gdm, disable lightdm, and enable gdm. I wasn’t sure if there would have been any negative effects so i just jumped all in.

    So ant77, your solution would be something similar to this?

    sudo pacman -S gdm
    sudo systemctl -f disable lightdm
    sudo systemctl -f enable gdm
    

    And if things went bad, then just revers it with

    sudo systemctl -f disable gdm
    sudo systemctl -f enable lightdm
    

    Would there be any issues with leaving lightdm? Would you then have to make sure light locker was disabled, or would it not matter since lightdm would be disabled? Does the alternative commands i just posted look correct?

  • @SirWeazel
    As far as I know, it is not required to have only one DM installed. Just don’t enable more than one at once ;)
    Thats what I did with Gnome several weeks ago and never had issues with GDM, so far:
    sudo pacman -S gdm
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    Not sure why do you use -f to enable/disable your dm?

    Intel NUC D54250WYK, 16 Gb RAM, 1 Tb SSD
    Multi -boot (no MS-Win &no UEFI) Legacy MBR with GPT

  • @ant77
    I think i read it on the antergos wiki on how to switch display managers. I didn’t think it was necessary since that was the only time i saw it used, but wasn’t sure. I think -f is just the force command. If it’s not needed, then i’ll remove it from my comments above and not use it in the future.
    Did you have to do anything to light-locker settings?

  • @SirWeazel
    I even forgot what light-locker settings I was using, lightdm is installed but it’s totally ignored by the system when you disable it. I remember the small lock in the upper right corner disappeared when I rebooted and the option to log out “the gnome way” appeared in the menu.

    Intel NUC D54250WYK, 16 Gb RAM, 1 Tb SSD
    Multi -boot (no MS-Win &no UEFI) Legacy MBR with GPT

gnome219 screensaver8 light locker5 Posts 18Views 9424
Log in to reply