• Automounting Samsung Galaxy


    In popular desktop environment like Gnome-automounting is installed automatically. Just have to plug-in USB key to access all your data in Nautilus.
    I have ARCH linux, and Gnome (without GNOME-EXTRA, without AUR). There is no problem with flash memory, but there is a problem with the Samsung Galaxy. For Antergos it works well, but not on ARCH. What do I need to do to telephone automounting automatically?

    https://wiki.archlinux.org/index.php/MTP -it does not work.

    I write here because it is very user-friendly forum :)

  • Hi,

    I suppose you already installed gvfs-mtp and followed this:
    https://wiki.archlinux.org/index.php/MTP#gvfs-mtp

    Cheers!

  • @karasu
    [[email protected] ~]$ lsusb

    Bus 002 Device 003: ID 04e8:6860 Samsung Electronics Co., Ltd GT-I9100 Phone [Galaxy S II], GT-I9300 Phone [Galaxy S III], GT-P7500 [Galaxy Tab 10.1] , GT-I9500 [Galaxy S 4]
    

    My **/etc/udev/rules.d/51-android.rules: **

    ATTR{idVendor}=="04e8", ATTR{idProduct}=="6860", SYMLINK+="libmtp",  MODE="660", ENV{ID_MTP_DEVICE}$
    

    This does not change anything, no mount, access denied. I in groups: wheel, users.

    [[email protected] ~]$ mtp-detect
    libmtp version: 1.1.9
    
    Listing raw device(s)
    Device 0 (VID=04e8 and PID=6860) is a Samsung Galaxy models (MTP).
       Found 1 device(s):
       Samsung: Galaxy models (MTP) (04e8:6860) @ bus 2, dev 6
    Attempting to connect device(s)
    ignoring libusb_claim_interface() = -6PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
    LIBMTP libusb: Attempt to reset device
    LIBMTP PANIC: failed to open session on second attempt
    Unable to open raw device 0
    OK.
    [[email protected] ~]$
    
  • I didn’t see this: For Antergos it works well, but not on ARCH

    So, why you don’t install Antergos in a VM and look for the differences? ;)

    (I’m just telling you that because I really don’t know how to help you :p).

    Maybe you have to set your phone in usb mode or accept usb access or something like that? (I do not own a Samsung)

    In Antergos we don’t mess much with configuration settings (I do not recall changing any udev rules, for instance), so my bet would be that if everything is ok with your mobile phone and your usb cable then you’re missing a package.

    Sorry I’m not of much help here.

    Cheers!

  • @karasu I reinstalled the system, installed gvfs-mtp , and it works. I wish that I came to this why not worked before. For sure I made a mistake at the previous installation.
    Zrzut ekranu z 2015-06-07 07-09-55.png

mtp2 samsung8 galaxy1 automounting2 data transfer1 Posts 5Views 1510
Log in to reply