• Problems while and after installing antergos


    Hi guys.

    I’m sorry for the cryptic title, I’m not sure how to phrase it better.

    I’ve downloaded yesterday (may, 29st) antergos, searching for an arch based liveusb distro. On the liveUSB things looked nice, qnd I decided to install. Here is where things started to get complicated:

    1. The wifi didn’t work properly. I understand that my wifi card is faulty and I solved this by placing options iwlwifi 11n_disable=1 in the file /etc/modprobe.d/iwlwifi.conf
    2. The installer version (cnchi?) version was 0.7.<somthing> and it stuck on the no wifi part though I had wifi launching it.
    3. cnchi-dev failed due to pyparted and python-parted collision. I solved this by removing both pyparted and cnchi-dev and installing cnchi-dev using yaourt

    I finally managed to install the OS. After starting it though, I had new problems

    1. wifi doesn’t work again. The fix didn’t work, though it might be possible I didn’t do this properly
    2. Brightness control doesn’t work properly. It did work well on the liveusb, but on the install, the response was slow and the brightness update froze for about 2 seconds between each key press. This problem occurs in Fedora as well, both in Gnome and Cinnamon desktop. It might be a GTK issue. I’m installing KDE to check this as I type this.
    3. The interface was in Hebrew, while Hebrew locals might be useful to me, I don’t want the interface to be Hebrew. I couldn’t find any place to chance this.

    I guess I wish to update you about the installer problem (which from a conversation I saw someplace I guess you something about) , and I hope you could help me with the other issues. Can I test things via virtual box?

    Thank you.


    Edit 1:
    I’m tested the brightness issue both with KDE and Cinnamon with the same behavior. I guess Gnome is not to blame, but who is?
    Edit 2:
    xbacklight set <number> seems to work better. There is a short lag of about quarter of a second which I’m not sure if it should exist or not. Sadly, it doesn’t update the brightness gui.

  • Hi,

    Your installation problems were because you were using a really old version of Cnchi. Latest stable is 0.8.131 (atm).
    Anyway, I’m glad the development version worked for you (you were lucky!).

    So you to know, there’re this testing iso’s that you might have tried (are always updated with the latest stable Cnchi, but not as fully tested as the one’s in our page antergos.com):
    http://build.antergos.com/browse/testing

    1. Wifi. Does lsmod show that your driver (iwlwifi) is loaded?
    2. Brightness… There are some kernel parameters that can be tried. For instance:
    • video.use_native_backlight=1
    • acpi_osi=!Windows 2012
      They have to be added to /etc/default/grub, but it depends on your hardware…
    1. Interface. In Gnome settings you can change your keyboard/language settings. If you want to change your system locale you must change /etc/locale.conf. You have more info here: https://wiki.archlinux.org/index.php/Locale Tell us if you have any doubts.

    Cheers!

  • Hi. Thanks for the replay.

    Sadly, I cannot allow myself at this time to be without a working machine. I tried to run antergos in a virtual machine (Box, provided by Fedora) but it gets its internet and brightness through the hosting machine. The image I downloaded was the “stable” link provided in the web site.

    1. Wifi. iwlwifi was loaded as I had to remove it.
    2. Brightness
      a. I toyed with some of them without success. The video.use_native_backlight=1 didn’t work, and from what I understand it is the default setting in the new kernels
      b. I added the acpi_osi option to the grub configuration file. I’ll update you after next boot.
    3. Interface, My concern was since I understood that this will affect the time zone. The local settings were part of the reason I left Arch linux and searched for GUI wrap around for that. I never understood them properly.
brightness13 wifi84 fn-keys1 install78 gnome229 Posts 3Views 1363
Log in to reply