• Wrong language after installation, how to change that?


    @karasu said:

    That looks like a bug to me. Could you create a new user? Just to see if with the new user works or not.

    Fresh test (non-admin) user has the same problem :(

    Think I’ll do a complete fresh install soon…

  • I just installed antergos for the first time today and I seem to have the same issue. I want English but I live in Belgium. How is the following possible?

    [[email protected] ~]$ locale
    LANG=nl_BE.UTF-8
    LC_CTYPE=“nl_BE.UTF-8”
    LC_NUMERIC=nl_BE.UTF-8
    LC_TIME=nl_BE.UTF-8
    LC_COLLATE=“nl_BE.UTF-8”
    LC_MONETARY=nl_BE.UTF-8
    LC_MESSAGES=“nl_BE.UTF-8”
    LC_PAPER=nl_BE.UTF-8
    LC_NAME=“nl_BE.UTF-8”
    LC_ADDRESS=“nl_BE.UTF-8”
    LC_TELEPHONE=“nl_BE.UTF-8”
    LC_MEASUREMENT=nl_BE.UTF-8
    LC_IDENTIFICATION=“nl_BE.UTF-8”
    LC_ALL=

    [[email protected] ~]$ localectl
    System Locale: LANG=en_US.UTF-8
    VC Keymap: us
    X11 Layout: n/a

    I also checked, I don’t have .config/locale.conf in my user home directory.

  • @Steven-Goris

    And your /etc/locale.conf?

    What do you get when you list your locales with localectl list-locales ?

  • The output of localectl matches the contents of my /etc/locale.conf. I will try list-locales again tomorrow but I thought that it just gave me a list with the available locales, nothing weird. I also tried to uncompile dutch but then I can’t open the terminal anymore because it still searches for this language.

    Update, exact output of list-locales:
    en_US.utf8
    nl_BE.utf8

  • Update: I think I found it!
    There is also a LANG variable in /etc/environment. Removing this one fixed it on my computer. 😌
    Finally! No J anymore instead of Y in the command prompt. 😄

  • I just signed up to say that this happened to me as well after a fresh installation from the current ISO.
    I selected my location to be Greece and my language to be English (GB); what I ended up with was Greek language and the timezone and formats of England :/

    I think I got it fixed by editing /etc/locale.gen and /etc/locale.conf, but the automatic timezone toggle still wants to place me in London.

  • Hello!

    I am aware that it is a pretty old thread but today I have been looking for the solution and unfortunately in this thread Even though that is exactly what I was looking for, ops is not solved ☹

    but i solved my case, i changed all config files specified in all guides and wki’s but i solved defining lenguage (as all the guides say in local config file) and executing sudo locale-gen and rebooting, <- rebooting not closing session XD. then i apply the lenguage and reboot again (just in case XD)
    now all of my keyboard layout and lenguage is applied, i can enjoy!
    but gnome-terminal not start, i solved returning lenguage to english but the keyboard layout is in my lenguage ☺

  • –closed–

    @hancok62 open a new thread if you want to ask a question or tell about a success!

language33 Posts 28Views 16868
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.