• Wrong language after installation, how to change that?


    Hi,

    After installing the testing release, I found that the language was different from the one I selected at the start of the installation dialog. The language had become the (default) language of the selected location instead. In my case: I prefer the Dutch language but I’m living in France. Selecting Dutch during install does not ‘stick’ if I then choose to set my location to France.

    Same goes for the input source. My keyboard was set to US international (QWERTY) during installation but after installation, it was suddenly French (AZERTY) which – if you’re not aware of it – will prevent login in due to a wrong password.

    I wonder what would happen if I had lived in Switserland where there are three languages possible ;)

    Anyway, how to change the language to Dutch now? If I go to the Gnome setting panel and choose “Pays & langue”, I can only select French. There are no other languages available. How to install them?

    Thanks :)

  • As far as the reason this happened, when installing, on the “Choose your location” step, part of the description is : The location you select will be used to help determine the system locale. In fact I had the same “problem”, I am Greek, but even though I chose English US as my location, the installer correctly identified Athens, Greece as my location, but everything else stayed in English.
    On GNOME I’m not sure about changing the locales, but I’m pretty sure there is a choice for the default locale. I will check it though and get back to you.
    For the keyboard sources, when adding a new language for (If I remember is a big + button), re-enable your primary choice, if you want to change layouts. And don’t forget the combination to change between the layouts.

  • Continuing from my previous post (I fired up the the Live GNOME session), i checked under Settings -> Region & Language and the first option was the language of the system and the second (below) option was the system formats. Unfortunately I couldn’t check the system’s behavior after an installation. Hopefully it will help you (though I don’t believe I was of much help).

  • Hi Noctem, thanks for the suggestions :) yes the keyboard layout can be changed even though it’s a hidden option: after hitting the + button, I had to drag the window border to increase viewport size which reveals the “Other” select option. This in turn reveals all possible keyboard layouts which can then be added. After that, deleting the incorrect layout is possible.

    This is not the case for “Language” or “Formats” however. There is only only option there whatever I do…

  • @Noctem said:

    Continuing from my previous post (I fired up the the Live GNOME session), i checked under Settings -> Region & Language and the first option was the language of the system and the second (below) option was the system formats. Unfortunately I couldn’t check the system’s behavior after an installation. Hopefully it will help you (though I don’t believe I was of much help).

    Yes, the settings are there. But no way to change them on my system :(

  • I believe then that this could be of help.

  • @Noctem said:

    I believe then that this could be of help.

    Sadly no… I manually edited /etc/locale.conf and also tried localectl set-locale ... (which does indeed change the system locale.conf file again) but every time (even after a reboot) locale-gen keeps creating the wrong locale. Very weird.

  • Sorry to hear that… My limited knowledge can only go this far. If I were you, as it’s a recent installation, I would reinstall the whole system. But that’s only me, not the best example of a user.

  • @karasu should know how you can fix this issue :grimacing:

  • @lots.0.logs I can try xD

    @RavanH :

    If I got everything right, you’ve fixed your keymap but you still are seeing everything in French and you want Dutch instead, is it?

    1. What does a locale -a show to you?

    2. Edit locale.gen : sudo nano /etc/locale.gen and be sure that:

    • All references to French (fr_) are commented with a #
    • Uncomment (remove #) to the nl_NL.UTF-8 UTF-8 line.
    1. Run locale-gen: sudo locale-gen you should see how the NL locale is build (but not the French one).

    2. Edit /etc/locale.conf and check that only the NL locales are there. It should look like this:

    LANG=nl_NL.UTF-8
    LC_COLLATE=nl_NL.UTF-8
    
    1. Check that you do not have any locale.conf file in your .config directory (so no ~/.config/locale.conf should be present)

    2. Run locale (without sudo) to see your user’s locale. Shows the correct one?

    3. If everything went well, just reboot to test the new locale.

    Tell us how it goes!

  • @karasu thans for the detailed steps :)

    1. first time locale -a gives me:
      C
      fr_FR.utf8
      POSIX

    2. I uncommented the dutch entry but left the french one uncommented too because I do want it to be available on the system, just not the default language…

    3. the sudo locale-gen gave me:

    Generating locales…
    en_US.UTF8… done
    fr_FR.UTF8… done
    nl_NL.UTF8… done
    Generation complete.

    1. but locale.conf still only contains LANG=nl_NL.UTF-8

    2. there’re no .config/locale.conf files on any user accounts.

    3. while locale still returns:

    LANG=fr_FR.UTF8
    LC_CTYPE="fr_FR.UTF8"
    LC_… (long list, all the same)
    LC_ALL=

    I rebooted, but still the same.

    Then I went to the System config panel > Languages and noticed that now I could select english or dutch as new language. I did this and was asked to reboot. Did that.

    However, even though the Languages gui now sais language (and format) is set to Dutch, the desktop and all dialog is still in French.

    Doing locale again results in the same list (with all fr_FR.UTF8) as before…

    I’m very confused about all this contradiction.

  • @RavanH

    I’m very confused about all this contradiction.

    Me too! ;)

    What’s the output of localectl status ?

  • @karasu said:

    What’s the output of localectl status ?

    System Locale: LANG=nl_NL.UTF8
    VC Keymap: us
    X11 Layout; us
    X11 Variant: alt-intl

    Which looks all good… except that everything is still in French :(

  • OK, then it’s a Gnome3 problem (or so it seems).

    Install dconf-editor, run it, and check which value do you have in System->locale

  • @karasu un System > Locale I only find “region” which is empty…

  • @RavanH : You don’t see something like this?

    region_and_language.png

  • @karasu no there is shows:
    Capture d'écran de 2015-06-03 17-21-06.png

  • @RavanH

    That’s really odd… it clearly says you have Dutch selected.

    I was so worried that I boot a VM with Antergos live ISO and guess what? Works flawlessly.

    What happens if you select ‘Langue’ ? In my VM I see this:

    language.png

    Have you tried to select a different language? (like English, for instance) What happens? Oh, you could try to select Dutch again, just in case.

  • @karasu I should maybe first repeat that I installed the testing release from about a week ago. Maybe that explains some differences…

    What happens if you select ‘Langue’ ? In my VM I see this:

    language.png

    I see only French, Dutch and US English. The three languages that where enabled after sudo locale-gen from step 3 in your earlier reply. Not any of the other languages…

    Have you tried to select a different language? (like English, for instance) What happens? Oh, you could try to select Dutch again, just in case.
    Like I said, I can switch between the three available languages and I’ll be asked to restart. But after confirming that, the language always stays French while the language setting displays the selected language correctly.

    Are there any language packs to be installed maybe?

  • @RavanH

    No language packs (that was some time ago). KDE has them, though.

    Like I said, I can switch between the three available languages and I’ll be asked to restart. But after confirming that, the language always stays French while the language setting displays the selected language correctly.

    That looks like a bug to me. Could you create a new user? Just to see if with the new user works or not.

language13 Posts 26Views 9257
Log in to reply