• I broke my system trying to get higher resolution after installing nvidia drivers. Help !


    I just ended up without a graphical interface aswell. I installed nvidia drivers and played with nvidia-xconfig because I had a really low resolution. Now everything just stops after “recovering journal”. I didn’t uninstall anything except later I tried an older version of the driver. Tried running lightdm manually.

    I’d really like my system back.

  • i have the same problem after i install nvidia (i think) i even config bumblebee but it only hows my nvidia drivers but dont detect my screen when i run "optirun -b none nvidia-settings -c :8"
    after i restart my laptop i encounter this errorr —> https://www.imageupload.co.uk/image/Z1wX

    distrohopp ere is the solution atleast worked for me after running nvidia-xconfig it creates a file “xorg.conf” in “/etc/X11” you can remove that file and startx you have your GUI back

  • @han2007
    You’re awesome. It worked. I’m back to 640x480 pixels.

    Startx. How did I forget that ?

    You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.

    Apparently “just” running this isn’t doing it.

  • well i run that to make the xorg config file but afer that i get that error and i remove the xorg everything went back to normal my prblem now is how can i install the nvidia

  • lspci | grep VGA
    00:0d.0 VGA compatible controller: NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)

    what about you ?
    I tried googling but found nothing relevant in 2 hours.

  • After I don’t know how many days of 640X480, I removed the driver. I don’t get why a system is able to automatically detect and set the correct resolution during instalation, but somehow it’s unable to just fix itself on a running system, cause I’m still there.

    I also don’t get where others find the necessary info to fix this, cause I’ve been looking and just ended up wasting time.

    I’m not even sure how to read this silence, it’s either I ran into a bug, failed to see the obvious in the wiki or there’s something wrong with my machine and it takes some unusaual effort to fix it.

  • since when you issue that command i assume that uses your nvidia card anyway you can check the screenshot below for my system graphics but i still cant get my nvidia to work
    http://imgur.com/ouWcvzS

    also below is my xorg.log and the image i take after i ran nvidia-xconfig :
    http://imgur.com/PZTk3eX

    if the screeshots werent available tell me too upload them again
    im afraid its related to my NVIDIA card that is being very new.

    also here is the xorg.conf that i generated manually : http://pastebin.com/VbSAauS5

    IF the image links are not available tell me to reupload them again

  • The original title was “I ‘broked’ my system”, a word-play on “bricked”. So while someone took the time and edited the title, I’m still on 640x480 since a week.

    There must be someone out there somewhere that can fix this, cause all my searches seem to return are unsolved topics from 9 years ago and other things that turn out to be unhelpful.

  • Alright so after scratching my head a lot, I took another look at the log file.

    cat /var/log/Xorg.0.log.old | grep -A5 -B2 304
    

    [ 8557.136] (II) Module “ramdac” already built-in
    [ 8557.138] (WW) NVIDIA(0): The NVIDIA GeForce 7025 / nForce 630a GPU installed in this
    [ 8557.139] (WW) NVIDIA(0): system is supported through the NVIDIA 304.xx Legacy
    [ 8557.139] (WW) NVIDIA(0): drivers. Please visit
    [ 8557.139] (WW) NVIDIA(0): http://www.nvidia.com/object/unix.html for more
    [ 8557.139] (WW) NVIDIA(0): information. The 352.09 NVIDIA driver will ignore this
    [ 8557.139] (WW) NVIDIA(0): GPU. Continuing probe…
    [ 8557.139] (EE) No devices detected.

    After reading this I installed 304.xx Legacy instead (Thanks to Murphy’s law, I tried all the others first of course.), ran nvidia-xconfig and now I have a resolution suited for 19" monitor on a 22", but I can change that from the now functional nvidia-settings.

    Aparently the 352.09 driver is stupider than the 304. Which is totally counter intuitive. If my GPU needs a certain flavor of the driver it should be differentiated differently. How on earth does this make sense ?

    If 304 is the first version that started supporting this GPU, Whatever comes after 304 should be less buggy and more capable to handle it, not the other way around. I swear I should sue.

    So no one in the entire Antergos comunity can see that in my original post I’m already talking about trying an older version ? I mean, I actually thought it would be something like this, but apparently i didn’t go old enough. Why didn’t anyone just say: “look, the numbers are there to fool you, you really need the right driver” ?

  • @distrohopp
    I’m new to the forum/community. Before i installed the nvidia drivers on my system, i verified the version with nvidia’s site. To be honest, i almost made the same mistake as you and installed too new of a driver. Nvidia tends to phase out older versions of their cards in the newer drivers. Probably because of compatibility with new hardware and technology.

    With that said, according to Nvidia’s site. The driver recommended for your card is
    Version: 304.125
    Release Date: 2014.12.5

    Also, i don’t think these forums are very active. Doesn’t seem to be a lot of people here compared to other forums. Sorry i didn’t read your post earlier, but i don’t know if i would have noticed the problem or not. Sometimes after i take a week from a problem, i come back to it and can’t believe i didn’t see what it was in the first place. Taking time and clearing you mind helps more often then one would think.

  • Where on earth

    @SirWeazel said:

    With that said, according to Nvidia’s site. The driver recommended for your card is
    Version: 304.125
    Release Date: 2014.12.5

    Where on earth does Nvidia’s site recommend a driver for my card ? I tried searching their site it returns nothing useful.
    They indeed recommend something named "Linux x64 (AMD64/EM64T) Display Driver " if you go and try downloading drivers. But who does that given that you have repos ? As a linux user I’m not downloading drivers, I use pacman.

    They indeed give you a long list of “Supported Products” where my product pops up too. Why on earth wouldn’t I presume that that list is an accumulation of all previous products ? I indeed didn’t check that list for newer drivers but why would I ? I didn’t even know what my graphics are in the first place.

    “Supported products” isn’t saying “This driver is the only one supporting the following products” or “Exclusively supported products”. Nowhere do I read: “caution, we’re dropping support in future versions”.

    Then there’s a section with “additional information”:

    Note that the list of supported GPU products is provided to indicate which GPUs are supported by a particular driver version.

    Was I supposed to infer that doesn’t mean other driver versions don’t support them ? Sure, the older ones might not. But why wouldn’t newer ones ?

    They go on saying that:

    Some designs incorporating supported GPUs may not be compatible with the NVIDIA Linux driver: in particular, notebook and all-in-one desktop designs with switchable (hybrid) or Optimus graphics will not work if means to disable the integrated graphics in hardware are not available. Hardware designs will vary from manufacturer to manufacturer, so please consult with a system’s manufacturer to determine whether that particular system is compatible.

    There is absolutely nothing recommending this version as being the only version that works Given the long list of supported products, one would think they just role support for every new product into a newer version of the driver.

    I have an issue, I’m trying to fix it, will I try to install an old buggy driver or wouldn’t it make more sense to try the newest ?

    The whole thing is upside down. You would think a company this big has the resourses to place some sense on their pages, but they don’t.

  • PS. I have no idea why I can’t edit my posts, but hey…

    I mean to clarifiy, that if the search results for my GPU are totally useless, why would I trust that selecting my card somewhere on a page that is supposed to give you your driver for download is the ultimate answer, especially if the driver looks old being called 304 instead of 352 ?

  • @distrohopp
    I wish i had a good answer for you. I’ve been in “driver hell” before with linux and windows. I understand the frustration, and don’t have a clear answer for you. All i can do is to share my experiences or what i usually do. You would think that newer is better, but that is not always the case. I’ve been burned before by that thinking when installing hardware drivers. When it comes to proprietary drivers, often the manufacturer phase stuff out.

    I tend to read too much. I’m the guy that sometimes reads the back of cereal boxes while eating breakfast. Since i’m new to antergos/arch, before installing my nvidia card i had to read the arch wiki, and that is where i noticed that you had to install the nvidia package for your specific model card. I almost just installed “nvidia” and left it at that. Why nvidia does what they do, i have no clue. I read what i did on the arch wiki and then went to nvidia and did there product selection stuff (but didn’t download anything). After telling nvidia what card i had, it shows the driver version and gives you the option to download. I then compared this to what arch had in their repos and used the repos for my install.

    Probably not the answer you were looking for. But at least you got it figured out. I’m still battling issues, which i think might be nvidia related also. It is what it is. Maybe if i had a laptop built for linux instead of windows, i would have fewer problems. Sorry i don’t have a better answer for you. I was just trying to help with what little knowledge i have.

  • This post is deleted!
  • I just created a brand new thread before I saw yours. I’m glad to see other folks are in nvidia hell. Not that I wish this on anyone but we can commiserate together as we find a solution.

Posts 15Views 3280
Log in to reply