• No display after installation - ASUS U38N Laptop


    Hey guys!
    First of all, you have a slightly cruel registration form (What’s the color of the advertisement below?), I’m colorblind, had to go get a friend to see the color for me :c
    Anyway, to my point:
    LiveUSB worked excellently on my laptop with nomodeset in boot parameters, installation worked fine as well. After reboot, I get the GRUB2 loader and everything, and as usual I add nomodeset after quiet, but this time I don’t get a display at all.
    So I tried modprobes, I tried various nomodeset commands, everything I tried ended the same way; once it’s done with the first set of commands and refreshes the display, the image never returns. Brightness is there (and modifiable), and I can input username and password (because I know how the login screen is supposed to look like) and I can hear the fans and CPU ramping up in response. But no matter what I do I can’t get display to work. Even after plugging in an external display.
    A friend suggested the ctrl+alt+f2…f6, and nothing happens onscreen.

    I even reinstalled 2 times, with different DE’s picked, to no avail.
    I really want to try out Antergos, anyone know what I can do?

  • Oh and just for info:
    The laptop I own is an ASUS U38N
    AMD Trinity A8 APU, 1.6Ghz
    Radeon HD 7600 series
    4GB RAM
    500GB HDD

  • Hi
    might be obvious for you not to, but have you tried to start Antergos without changing anything in Grub after completing the installation ?

  • Yeah, tried that too, no dice :c

    UPDATE:
    So. Got a buddy that runs Antergos to help me. Managed to get an HDMI secondary display to work (VGA doesn’t), and all I got was command-line. Turned out x server couldn’t start. Startx coughed up errors, including "xterm: program not found . So I did pacman -S xterm, and then I could start X. But I only got Xorg to work, in its most basic format. So I read somewhere that disabling lightdm and installing and enabling gdm solved it for some, so I did that, and true enough got a window manager to work. But I still couldn’t get my laptop display to work, tried installing a new DE (the MATE one I installed didn’t work at all), tried setting new kernel parameters, but no dice.
    In the end I gave up, I imagine the .ISO I used must’ve been broken or something since neither xterm og MATE got installed as it was supposed to.
    Went and picked up Manajaro LXDE Edition, it booted up and installed without problem, and subsequently booted perfectly fine with nomodeset and is working flawlessly, proving that Arch Linux is not the issue, but something else is…

    I’m still willing to try and get it to work if someone suggests a plausible solution, Antergos just looks so nice c:

  • Hi i have the exact same problem, i also have the same Laptop you have, and i also tryed the same things before looking for help.
    If you definetly find out how to solve this please post it i will if i get it solved.
    thanks.

    Edited:
    I have finally found a solution to the problem!! :)
    Just add the following in kernel parameters after quiet

    radeon.modeset=0 rd.blacklist=radeon nomodeset

    Note that this solution disables the radeon module so you will be using vesa mode.
    But this enables you to have Xorg working and to be able to install the propietary Ati drivers.
    With this laptop is highly recommended to install the propietary Ati drivers

nomodeset2 display30 u38n1 Posts 5Views 1518
Log in to reply