• Issues with GUI


    So, I was having some issues with screen flickering after a recent update, and i figured it was the graphics driver, so I tried installing the drivers for meant for the graphics card I have, and uninstalling the ones that were on there, and now there is no GUI at all, just a command line. New to linux, just switched over from Windows, no idea what I’m doing.

  • @weweeq-qeqewq said:

    no idea what I’m doing.

    Do not worry, everybody has been at your place sometime ;)

    OK, we need a more specific report. Can you tell us:

    • Which graphics card do you have?
    • Which driver where you using?
    • Which driver did you try to install?

    It would be also helpful if you can reproduce here the steps you took to replace the driver, so we can see where you were wrong.

    Cheers!

  • so I tried installing the drivers for meant for the graphics card I have, and uninstalling the ones that were on there,

    I really don’t think removing anything was necessary. Could he have removed something essential that the new driver was relying on ? Do you remember what exactly you uninstalled ? Reverting that might solve your problem.

    You can hopefully seek through your command line history with CTRL-R.

  • @karasu I have an intel graphics card, i had nvidia drivers installed and I tried to install the default drivers for intel. I think like distrohopp said I might have accidentally removed something while I was uninstalling it, but I’m not sure what.

  • OK, if you have an intel card, you should use the intel graphic driver ;)

    Try installing these packages, from the command line:

    sudo pacman -Syu
    sudo pacman -S xf86-video-intel mesa-libgl
    

    You have a lot of info here: https://wiki.archlinux.org/index.php/Intel_graphics

    Tell us if installing the intel graphics driver helps or not. Maybe you have something else wrong in your installation.

    Cheers!

  • @karasu That does not appear to have worked. I did check and it looks like some packages were removed, I was able to cinnamon and gdm, but I’m not sure which other packages might be missing. I think when I uninstalled the nvidia drivers the first time, it removed some packages as dependancies.

  • @weweeq-qeqewq

    You have a log in /var/log/pacman.log ? There you will be able to see what was removed.

    Cheers!

  • @karasu Not to sound stupid or anything, but how do I access that? Do I need to use a command of some sort or just type it in?

  • @weweeq-qeqewq You can access it using the Nemo (file manager) in Cinnamon. :smile:

    Cheers!

  • Okay, I managed to get it fixed. :) Thanks for all the help.

Posts 10Views 1914
Log in to reply