• Feeling noobish trying to fix screen resolution, solved but suggestions needed.


    So I just wasted an hour fixing my screen resolution.

    I tried

    pacman -Qs screen
    

    nothing relevant came up. There’s a menu item in openbox called “screen resolution” linking to “ARandR Screen Layout Editor 0.1.7.1” that was totally useless given that my previous resolution wasn’t listed. Looking into Layout properties, to my surprise I found some script referencing “xrandr”. Why on earth didn’t xrandr show up with pacman -Qs screen ? What was I supposed to do to find it ?

    Meanwhile I tried xprofile, it didn’t work, tried git version, it didn’t work, it complained about some missing docutils, something with python came up, I tried the one with python2 given that it’s 6 years old, of course it needed the other one… Then I tried to figure out how to work with xprofile,

    xprofile 
    usage: xprofile [-h] [--verbose] [--config CONFIG] [--version]
                {list,current,generate,activate} ...
    xprofile: error: the following arguments are required: subcommand
    

    it turns out the above means, you use it like this:

    xprofile list
    

    tried generating, listing, and then activating. It didn’t list or activated anything after generating. So I gave up.

    Googling among other useless info brought me to a forum where people were using xrandr --new-mode and --add-mode. So I created a mode that now I know already existed somehow, but wasn’t showing up in arandr.

    It turns out all I really would have neeeded to do was run:

     xrandr --output VGA-1 --auto
    

    But google won’t tell you anything relevant and if you look at the wiki and you’ll see:
    2 Testing_configuration
    5 Troubleshooting >
    5.1 Adding undetected resolutions

    Since my previous resolution didn’t show up in arandr, I thought I was supposed to add it, and went on reading 5.1 Yet the info I actually needed was at the top of the page at section 2. I have absolutely no idea why but arandr now actually lists all my resolutions.

    While I’m not exactly ranting here, I’ve been meaning to post about situations like this, cause I kinda run into it too often. Wouldn’t listing and applying configurations be a better title on the wiki ?

    Either Linux is full of little caveats, or after all these years I still don’t know how to troubleshoot things without wasting an hour on something that normally should take you 2 minutes using a GUI.

    So I really just want to know how the more experienced users work things like this out and if there’s a simpler, alternative, way to do this.

  • I didn’t have the problem you had but I knew my graphics card (Intel) supported resolutions up to 1920x1080.
    I went Googling and found

    http://gtk-apps.org/content/show.php/newrez±+Increase+Screen+Rez+For+Netbook?content=134686

    The syntax is

    for example:
    newrez 1920x1080
    If it doesn’t do the resolution exactly, it will get very close.

    Hope this is of some help.

  • @herbie Thanks. So different people google differently. You’re results may vary.

    Let’s say you’re minding your own business in a remote village. No internet. Than this happens. You can’t google anything, you can’t download anything. You just want your screen back.

    man xrandr, as painfully unhelpful as it is, does have some examples and references cvt too, in time you’d probably figure it out. But how do I get to xrandr offline ?

  • Download it and check what it does.
    I believe it runs xrandr.
    I looked at the script, but, I am a bit remiss in understanding the script.
    I think it is about here
    on line 65

    newH=echo $newrez | cut -d'x' -f1
    newV=echo $newrez | cut -d'x' -f2
    modeline=cvt $newH $newV $HZ | grep Modeline
    newmode=echo "$modeline" | sed 's/^.*"//'
    cvtrez=echo "$modeline" | sed -e 's/_.*//' -e 's/^.*"//'

    if [ “$newrez” != “$cvtrez” ]
    then newrez=$cvtrez
    newH=echo $newrez | cut -d'x' -f1
    newV=echo $newrez | cut -d'x' -f2
    fi

  • What I would do is download newrez and just keep in you home directory.
    I should have said that in the beginning.
    That way it is always available. I do that with a few programs.
    If I install a new distro, I don’t have to go searching again.

  • @herbie

    I appreciate your input. But I could simply store a text file in my home directory saying “for screen resolution issues xrandr is the tool to mess with”. Being a distrohopper who knows where this home directory will end up one day… backed up on a shelf.

    The issue occurs like once every 2 years to me on avarage, long enough to forget that I used xrandr last time.

    I’m just really interested in learning what Linux has in mind for this. One would think you can get around your system without forums, right ?

    pacman -Qs display
    

    local/lib32-libxdmcp 1.1.2-1
    X11 Display Manager Control Protocol library (32-bit)
    local/lib32-wayland 1.7.0-1
    A computer display server protocol
    local/libxdmcp 1.1.2-1
    X11 Display Manager Control Protocol library
    local/lightdm 1:1.14.0-2
    A lightweight display manager
    local/qt5-svg 5.4.1-5 (qt qt5)
    Classes for displaying the contents of SVG files
    local/startup-notification 0.12-4
    Monitor and display application startup
    local/wayland 1.7.0-1
    A computer display server protocol
    local/xorg-xdpyinfo 1.3.2-1 (xorg-apps xorg)
    Display information utility for X
    local/xorg-xlsclients 1.1.3-1 (xorg-apps xorg)
    List client applications running on a display
    local/xorg-xprop 1.2.2-1 (xorg-apps xorg)
    Property displayer for X
    local/xorg-xvinfo 1.1.2-2 (xorg-apps xorg)
    Prints out the capabilities of any video adaptors associated with the
    display that are accessible through the X-Video extension
    local/zenity 3.16.2-1
    Display graphical dialog boxes from shell scripts

  • Should I start a new topic ? I decided I actually install some drivers, so I did.

    Now I’m down to this:
    xrandr xrandr: Failed to get size of gamma for output default Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480 default connected 640x480+0+0 0mm x 0mm 640x480 73.00*

    Tried nvidia-settings and skimmed through the wiki. What do I do ?

Posts 7Views 1693
Log in to reply