• locking and switching user problems


    Thanks in advance for any help. When attempting to lock the screen or switch to another user, i get a white screen with a black mouse cursor. As a work around, i’ve disabled “locking” in the light locker settings. I usually just switch to another terminal using function keys and reboot when this happens.
    Symptons:

    1. When locking the computer i get a white screen with a black mouse cursor.
    2. When trying to use the “switch user” from gnome in the top right, nothing happens.
    3. When running “dm-tool switch-to-greeter” from command line, it also drops me to the white screen with black mouse cursor.

    Notes/Hardware:

    1. This is an ASUS laptop g2s-extreme with nvidia geforce 8600m gt 256MB.
    2. Using NVIDIA drivers 340.76
    3. Installed 64bit antergos with the testing build iso, gnome, and all extra options except the uncomplicated firewall.
    4. Because of a bug in clutter with nvidia drivers, i added CLUTTER_BACKEND=x11 to /etc/enviroment. The bug was preventing maps, totem, and some other apps from opening. I’ve undid this tweak also, but I still get the problem. Could this issue be causing my locking problem?
      REFERENCE: https://bbs.archlinux.org/viewtopic.php?id=196029
    5. Software i’ve installed from the default setup. Chrome, Steam, Citrix, Oracle Java, tn5250j. Possibly missed a program here or there.

    Maybe i’m completely off base, but i think the problem may be with the greeter, light-locker, screensaver, nvidia?
    Let me know what logs you want, and i will provide them. If you want a log, let me know if you want me to reproduce the problem then copy of the log or just give you logs as is. Thanks

  • Hi,

    Please follow the HOW TO sticky post for obtaining the appropriate logs. Post them here and we’ll take a look :smile:

    Cheers!

  • Attaching logs. I may have actually even included a couple extra log files if they were in a given directory. While trying to fix the issue on my own, i deleted /var/cache/lightdm and let it rebuild itself.
    logs.tar

  • It appears you are also affected by a new bug in webkitgtk. There havent been any solid reports posted upstream. It would be great if you could report it upstream and provide your logs to them. This is the important information from the journal log:

    kernel: WebKitWebProces[822]: segfault at 0 ip 00007fa61272ab61 sp 00007ffcd9c48d00 error 4 in libwebkit2gtk-4.0.so.37.6.6[7fa610d82000+214d000]
    May 26 02:01:19 gollum systemd-coredump[837]: Process 822 (WebKitWebProces) of user 620 dumped core.
    

    Unfortately this is beyond my knowledge level so we’ll have to wait for it to be fixed upstream :grimacing:

  • Do you think the bug has to do with the nvidia driver? Similar to the clutter issue i was having? I was going to remove the nvidia driver, but then i was prompted that it also wanted to remove xorg and several other software packages making it appear more complicated to uninstall as it was to install them. Thank you for the help. Where exactly should i report the bug at?

  • No, its not related (at least not directly) because other users have reported the issue with intel graphics. Could you provide the output of the following command? Thanks.

    ldd /usr/bin/lightdm-webkit2-greeter
    
  • Attached is the output from
    ldd /usr/bin/lightdm-webkit2-greeter
    ld.tar

  • @SirWeazel Thanks, I just wanted to make sure that there were no missing dependencies on the package. (Which it looks like they are all there).

  • Thanks. I won’t have this laptop with me for the next week, but will be keeping on eye on this forum. If you need any further information i will be able to post logs and stuff on Fri/Sat. Maybe when i power it up on Friday i will have some updates that will fix the problem. Next step… learn gnome. It’s been a hate/love relationship so far. Not sure what i think of it yet.

    Also as a side note. I think i’m experiencing the screen flickering bug I read about somewhere. Looks like i need to research that also.

  • ALMOST SOLVED, JUST NEED A LITTLE MORE HELP…

    I fixed the white screen with black cursor and the locking screen problem. I can now lock the screen on command, lock from suspend, lock and log in as another user. So i think that part is fixed.
    I had to create a the file at:

    /etc/X11/xorg.conf.d/20-nvidia.conf
    

    And populate the file with:

    Section "Device"
        Identifier "Nvidia Card"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
    EndSection
    

    Reference i used: https://bbs.archlinux.org/viewtopic.php?id=192259
    Now i need help figuring out why “switch user” does not do anything. It’s like it is supposed to be triggering an action or event, but it doesn’t do anything. I’m not even sure if it is logging an event.

  • Update:
    I’ve also noticed when attempting to use the “switch user” under my user name that it generates the following in the logs.

    (gnome-shell:557): Gjs-WARNING **: JS ERROR: Gio.DBusError: Unable to create transient display: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.DisplayManager was not provided by any .service files
    
    Indicator<._onLoginScreenActivate/<@resource:///org/gnome/shell/ui/status/system.js:386
  • Another Update:
    My issues are now solved. The reason i think “switch user” did nothing was because of lightdm. Since i’m only concerned with the gnome desktop, i decided to switch to gnome display manager (gdm). Doing this resolved all my issues. Now screen locking, switching, power saving, ect… are all working. I haven’t tried removing the nvidia.conf file i created to get lightdm to work, so i’m not sure if it is still needed. I don’t think it is, and may try messing/removing the conf at another date. It is so much quicker from resume. My recommendation if you are just using gnome is to go this route. I used the instructions from the antergos wiki:
    http://antergos.com/wiki/desktops/installing-display-managers/
    BEFORE SWITCHING DISPLAY MANAGER, PLEASE UNDERSTAND WHAT YOUR ARE DOING AND RESEARCH ACCORDINGLY.

    sudo pacman -Rcns lightdm
    sudo pacman -S gdm
    sudo systemctl -f enable gdm
    

    @lots-0-logs
    Thanks for helping/responding earlier. Now when the forum software gets updated i could mark as solved.

  • My pc also had the same problems with lightdm (Intel based Lenovo G4070), so, uninstalled lightdm and installed gdm, the problems are gone.

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • Forum has been fixed, and i can now mark this as solved. Also making a note that i’ve tried removing the CLUTTER_BACKEND=x11 to /etc/enviroment fix i made earlier but it still gave me troubles. I was able to launch maps and totem but suspend issues came back. I currently don’t see a down side to this and probably will leave it.

Posts 14Views 3138
Log in to reply