• Multiple Segfaults (vlc, gtk2, gtk3, librsvg, gdk-pixbuf2, fmtutil, lib32-gtk2, libwmf)


    When I run VLC, it simply segfaults. I have tried updating to the git version with the same result.

    [[email protected] ~]$ vlc -v
    VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
    [0000000002056118] core libvlc warning: cannot read /usr/lib/vlc/plugins/plugins.dat: No such file or directory
    Segmentation fault (core dumped)

    Any help is appreciated. Thank you.

  • Hi,

    That’s exactly the version I have. No problems here. I don’t really know what’s happening to you, but…

    • Are you running 32bit or 64bit system?
    • Which graphics card do you have? And driver?
    • Have you tried to wipe out vlc config dir? (it’s ~/.config/vlc)

  • 64bit

    Nvidia GForce GTX 770 (with nvidia driver)

    It has never worked long enough to create it.

  • Try this:

    su
    pacman -Rccn vlc vlc-git # exclude whichever one you don't have installed currently from this command
    rm -rf ~/.config/vlc ~/.cache/vlc ~/.local/share/vlc
    pacman -Syyu
    pacman -S vlc
    exit
    
  • This post is deleted!
  • [[email protected] eadword]# pacman -S vlc
    warning: vlc-2.2.1-4 is up to date -- reinstalling
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (1) vlc-2.2.1-4
    
    Total Installed Size:  47.92 MiB
    Net Upgrade Size:       0.00 MiB
    
    :: Proceed with installation? [Y/n] Y
    (1/1) checking keys in keyring                                                     [################################################] 100%
    (1/1) checking package integrity                                                   [################################################] 100%
    (1/1) loading package files                                                        [################################################] 100%
    (1/1) checking for file conflicts                                                  [################################################] 100%
    (1/1) checking available disk space                                                [################################################] 100%
    (1/1) reinstalling vlc                                                             [################################################] 100%
    /tmp/alpm_03oQr6/.INSTALL: line 1: 16666 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    

    Also, I did run the rm -rf command as both root and myself though I doubt that has anything to do with this result; though despite this, it claims to be installed, but has the same problem as before.

  • @karasu was correct, you need to remove vlc from your package cache. Try again:

    su
    pacman -Rccn vlc
    rm /var/cache/pacman/pkg/vlc***
    # Might as well refresh your mirrorlist
    pacman -S reflector
    reflector -l 40 -f 20 --save /etc/pacman.d/mirrorlist
    pacman -Syyu
    pacman -S vlc
    
  • Unfortunately I am still getting the same error.

    [[email protected] ~]$ su
    Password: 
    [[email protected] eadword]# pacman -Rccn vlc
    checking dependencies...
    
    Packages (1) vlc-2.2.1-4
    
    Total Removed Size:  47.92 MiB
    
    :: Do you want to remove these packages? [Y/n] Y
    (1/1) removing vlc                                 [######################] 100%
    [[email protected] eadword]# rm /var/cache/pacman/pkg/vlc-2.2.1-
    vlc-2.2.1-2-x86_64.pkg.tar.xz  vlc-2.2.1-4-x86_64.pkg.tar.xz
    vlc-2.2.1-3-x86_64.pkg.tar.xz  
    [[email protected] eadword]# rm /var/cache/pacman/pkg/vlc-2.2.1-
    vlc-2.2.1-2-x86_64.pkg.tar.xz  vlc-2.2.1-4-x86_64.pkg.tar.xz
    vlc-2.2.1-3-x86_64.pkg.tar.xz  
    [[email protected] eadword]# rm /var/cache/pacman/pkg/vlc***
    [[email protected] eadword]# pacman -S reflector
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (1) reflector-2014.11-1
    
    Total Download Size:   0.01 MiB
    Total Installed Size:  0.08 MiB
    
    :: Proceed with installation? [Y/n] Y
    :: Retrieving packages ...
    reflector-2014.11-1-any   14.6 KiB   429K/s 00:00 [######################] 100%
    (1/1) checking keys in keyring                     [######################] 100%
    (1/1) checking package integrity                   [######################] 100%
    (1/1) loading package files                        [######################] 100%
    (1/1) checking for file conflicts                  [######################] 100%
    (1/1) checking available disk space                [######################] 100%
    (1/1) installing reflector                         [######################] 100%
    Optional dependencies for reflector
       rsync: rate rsync mirrors
    [[email protected] eadword]# reflector -l 40 -f 20 --save /etc/pacman.d/mirrorlist
    [[email protected] eadword]# pacman -Syyu
    :: Synchronizing package databases...
    core                     122.5 KiB   253K/s 00:00 [######################] 100%
    extra                   1723.9 KiB   730K/s 00:02 [######################] 100%
    community                  2.6 MiB   807K/s 00:03 [######################] 100%
    multilib                 125.8 KiB   222K/s 00:01 [######################] 100%
    antergos                 397.0 KiB   608K/s 00:01 [######################] 100%
    :: Starting full system upgrade...
    there is nothing to do
    [[email protected] eadword]# pacman -S vlc
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (1) vlc-2.2.1-4
    
    Total Download Size:    9.50 MiB
    Total Installed Size:  47.92 MiB
    
    :: Proceed with installation? [Y/n] Y
    :: Retrieving packages ...
    vlc-2.2.1-4-x86_64         9.5 MiB   856K/s 00:11 [######################] 100%
    (1/1) checking keys in keyring                     [######################] 100%
    (1/1) checking package integrity                   [######################] 100%
    (1/1) loading package files                        [######################] 100%
    (1/1) checking for file conflicts                  [######################] 100%
    (1/1) checking available disk space                [######################] 100%
    (1/1) installing vlc                               [######################] 100%
    /tmp/alpm_P23lPz/.INSTALL: line 1: 17626 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    Optional dependencies for vlc
       avahi: for service discovery using bonjour protocol [installed]
       libnotify: for notification plugin [installed]
       gtk2: for notify plugin [installed]
       ncurses: for ncurses interface support [installed]
       libdvdcss: for decoding encrypted DVDs [installed]
       lirc: for lirc plugin [installed]
       libavc1394: for devices using the 1394ta AV/C [installed]
       libdc1394: for IEEE 1394 plugin [installed]
       kdelibs: KDE Solid hardware integration [installed]
       libva-vdpau-driver: vdpau back-end for nvidia [installed]
       libva-intel-driver: back-end for intel cards [installed]
       libbluray: for Blu-Ray support [installed]
       flac: for Free Lossless Audio Codec plugin [installed]
       portaudio: for portaudio support [installed]
       twolame: for TwoLAME mpeg2 encoder plugin [installed]
       projectm: for ProjectM visualisation plugin [installed]
       libcaca: for colored ASCII art video output [installed]
       libgme: for libgme plugin [installed]
       librsvg: for SVG plugin [installed]
       gnome-vfs: for GNOME Virtual File System support [installed]
       libgoom2: for libgoom plugin [installed]
       vcdimager: navigate VCD with libvcdinfo [installed]
       aalib: for ASCII art plugin [installed]
       libmtp: for MTP devices support [installed]
       smbclient: for SMB access plugin [installed]
       libcdio: for audio CD playback support [installed]
       ttf-freefont: for subtitle font [installed]
       ttf-dejavu: for subtitle font [installed]
       opus: for opus support [installed]
       libssh2: for sftp support [installed]
       lua-socket: for http interface [installed]
    [[email protected] eadword]# exit
    exit
    [[email protected] ~]$ vlc
    VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
    Segmentation fault (core dumped)
  • @Eadword

    OK, what’s the output of this command?
    sudo /usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins

  • [[email protected] ~]$ sudo /usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    [sudo] password for eadword: 
    [[email protected] ~]$
    

    And running vlc yields the same error as before.

  • I’m having the same issue with VLC. It used to work fine on this system though; it broke sometime in the last month. I get segfaults not just when I try to run VLC, but also when I try to install it, both the package from the main repos and from git. I tried all the above suggestions and they haven’t helped me either. Also a 64 bit system, proprietary NVidia drivers, with a GeForce GTX 860M.

    I checked the pacman.log file and found the segfaults were logged there as well, and I noticed vlc wasn’t the only package giving these errors – it’s also showing up after upgrading gtk2, gtk3 and librsvg. If I install those packages manually I get segfaults too:

    $ sudo pacman -S gtk3
    [sudo] password for urza9814: 
    warning: gtk3-3.16.3-2 is up to date -- reinstalling
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (1) gtk3-3.16.3-2
    
    Total Installed Size:  66.47 MiB
    Net Upgrade Size:       0.00 MiB
    
    :: Proceed with installation? [Y/n] 
    (1/1) checking keys in keyring                      [###########################] 100%
    (1/1) checking package integrity                    [###########################] 100%
    (1/1) loading package files                         [###########################] 100%
    (1/1) checking for file conflicts                   [###########################] 100%
    (1/1) checking available disk space                 [###########################] 100%
    (1/1) reinstalling gtk3                             [###########################] 100%
    /tmp/alpm_8LrNUi/.INSTALL: line 1: 26052 Segmentation fault      (core dumped) /usr/bin/gtk-query-immodules-3.0 --update-cache
    
    $ sudo pacman -S vlc
    [sudo] password for urza9814: 
    warning: vlc-2.2.1-4 is up to date -- reinstalling
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (1) vlc-2.2.1-4
    
    Total Installed Size:  47.92 MiB
    Net Upgrade Size:       0.00 MiB
    
    :: Proceed with installation? [Y/n] 
    (1/1) checking keys in keyring                      [###########################] 100%
    (1/1) checking package integrity                    [###########################] 100%
    (1/1) loading package files                         [###########################] 100%
    (1/1) checking for file conflicts                   [###########################] 100%
    (1/1) checking available disk space                 [###########################] 100%
    (1/1) reinstalling vlc                              [###########################] 100%
    /tmp/alpm_qnKSzC/.INSTALL: line 1:  3734 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    

    The first instance of it was during a system upgrade I ran on May 12th:

    [2015-05-12 23:58] [ALPM] upgraded librsvg (1:2.40.9-1 -> 1:2.40.9-2)
    [2015-05-12 23:58] [ALPM-SCRIPTLET] /tmp/alpm_9kBgpF/.INSTALL: line 1: 20327 Segmentation fault      (core dumped) gdk-pixbuf-query-loaders --update-cache
    

    I googled that error a bit and saw some suggestions to update my CPU microcode but that doesn’t seem to have helped either. Anyone have any suggestions where to go from here? Eadword, do you have these same errors in your /var/log/pacman.log?

  • I am defiantly seeing it for VLC, GTK 2 and 3, and librsvg. In addition, I see gdk-pixbuf2, fmtutil, lib32-gtk2, libwmf, and that seems to be all.

    It is also worth noting that VLC has had this problem since the initial install about a month or so ago (probably longer). I am fairly certain it was having this problem before installing the NVIDIA drivers as well.

  • I am also having this issue

  • Assuming we’re all facing the same issue here, maybe we can check if we all installed some common packages before this started? I’ve narrowed it down to a couple dozen on my system, so if we each post a list maybe we can compare…or you could post the whole pacman.log and I could sort through it, either way works for me :) I just want my VLC back :(

    First thing I did was execute the following command to find exactly which packages were causing the segfaults:

    $ cat /var/log/pacman.log | grep -B 1 Segmentation
    

    This produced the following output, from which I found librsvg, gtk2, gtk3, and vlc causing issues on my system:

    [2015-05-12 23:58] [ALPM] upgraded librsvg (1:2.40.9-1 -> 1:2.40.9-2)
    [2015-05-12 23:58] [ALPM-SCRIPTLET] /tmp/alpm_9kBgpF/.INSTALL: line 1: 20327 Segmentation fault      (core dumped) gdk-pixbuf-query-loaders --update-cache
    --
    [2015-05-12 23:58] [ALPM] upgraded gtk2 (2.24.27-1 -> 2.24.27-2)
    [2015-05-12 23:58] [ALPM-SCRIPTLET] /tmp/alpm_h3PD9n/.INSTALL: line 1: 20367 Segmentation fault      (core dumped) /usr/bin/gtk-query-immodules-2.0 --update-cache
    --
    [2015-05-12 23:58] [ALPM] upgraded gtk3 (3.16.2-1 -> 3.16.3-1)
    [2015-05-12 23:58] [ALPM-SCRIPTLET] /tmp/alpm_bfsz2H/.INSTALL: line 1: 20794 Segmentation fault      (core dumped) /usr/bin/gtk-query-immodules-3.0 --update-cache
    --
    [2015-05-13 00:01] [ALPM] upgraded vlc (2.2.1-2 -> 2.2.1-3)
    [2015-05-13 00:01] [ALPM-SCRIPTLET] /tmp/alpm_Pba8m5/.INSTALL: line 1:  8195 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    

    So then I wanted to find the first segfault from one of these packages, and also the last time any of these specific packages had installed correctly. I used the below command to do that; if other packages are causing segfaults you’ll want to add those to the first grep:

    $ grep -n 'vlc\|gtk2\|gtk3\|librsvg\|Segmentation' /var/log/pacman.log | grep -B 10 Segmentation | head -20
    

    The output of that gave me:

    6796:[2015-04-16 18:03] [PACMAN] Running 'pacman --color auto -S extra/vlc'
    6798:[2015-04-16 18:03] [ALPM] reinstalled vlc (2.2.0-2)
    6982:[2015-04-21 21:45] [ALPM] upgraded vlc (2.2.0-2 -> 2.2.1-2)
    7043:[2015-05-12 23:58] [ALPM] upgraded librsvg (1:2.40.9-1 -> 1:2.40.9-2)
    7044:[2015-05-12 23:58] [ALPM-SCRIPTLET] /tmp/alpm_9kBgpF/.INSTALL: line 1: 20327 Segmentation fault      (core dumped) gdk-pixbuf-query-loaders --update-cache
    7047:[2015-05-12 23:58] [ALPM] upgraded gtk2 (2.24.27-1 -> 2.24.27-2)
    7048:[2015-05-12 23:58] [ALPM-SCRIPTLET] /tmp/alpm_h3PD9n/.INSTALL: line 1: 20367 Segmentation fault      (core dumped) /usr/bin/gtk-query-immodules-2.0 --update-cache
    

    So then I just opened my /var/log/pacman.log file in my text editor and cut lines 6982 to 7043, which I’ve pasted at the below link. If you two could do the same we could see if it might be caused by something else we installed.

    http://pastebin.com/qJYF7TJg

  • Before I do that, I will admit that I am responsible for Rimm’s post; he is a friend who I converted to Antergos and who just so happened to have the same problem. Now, from what I know of his system and mine, it would seem that a likely cause might be Nvidia drivers. I know we are both using the proprietary drivers and he has a similar card (GeForce GTX 660). Therefore the graphics drivers are at the top of my suspicions.

    As for your process, mine was popping up at lines 70 to 234:

    [[email protected] ~]$ grep -n 'vlc\|gtk2\|gtk3\|librsvg\|Segmentation' /var/log/pacman.log | grep -B 10 Segmentation | head -20
    70:[2015-05-03 00:18] [ALPM] installed vlc (2.2.1-2)
    71:[2015-05-03 00:18] [ALPM-SCRIPTLET] /tmp/alpm_QNlG2p/.INSTALL: line 1:  3503 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    89:[2015-05-03 00:33] [ALPM-SCRIPTLET] /tmp/alpm_mELaD2/.INSTALL: line 1:  5873 Segmentation fault      (core dumped) gdk-pixbuf-query-loaders > etc/gtk-2.0/gdk-pixbuf.loaders
    95:[2015-05-03 00:34] [ALPM] installed wxgtk2.8 (2.8.12.1-3)
    132:[2015-05-03 08:37] [ALPM] installed webkitgtk2 (2.4.8-2)
    152:[2015-05-03 12:32] [ALPM] reinstalled vlc (2.2.1-2)
    153:[2015-05-03 12:32] [ALPM-SCRIPTLET] /tmp/alpm_rGcw0N/.INSTALL: line 1: 23526 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    157:[2015-05-03 12:38] [PACMAN] Running 'pacman -S vlc'
    159:[2015-05-03 12:38] [ALPM] reinstalled vlc (2.2.1-2)
    160:[2015-05-03 12:38] [ALPM-SCRIPTLET] /tmp/alpm_6LFldL/.INSTALL: line 1:  1408 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    162:[2015-05-03 12:45] [PACMAN] Running 'pacman -S --force vlc'
    164:[2015-05-03 12:45] [ALPM] reinstalled vlc (2.2.1-2)
    165:[2015-05-03 12:45] [ALPM-SCRIPTLET] /tmp/alpm_rn55ie/.INSTALL: line 1:  1187 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    168:[2015-05-03 12:46] [ALPM] removed vlc (2.2.1-2)
    170:[2015-05-03 12:47] [PACMAN] Running 'pacman -S vlc'
    172:[2015-05-03 12:47] [ALPM] installed vlc (2.2.1-2)
    173:[2015-05-03 12:47] [ALPM-SCRIPTLET] /tmp/alpm_rZPuDA/.INSTALL: line 1:  1669 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    230:[2015-05-06 21:50] [ALPM] upgraded librsvg (1:2.40.9-1 -> 1:2.40.9-2)
    231:[2015-05-06 21:50] [ALPM-SCRIPTLET] /tmp/alpm_oZ8pgh/.INSTALL: line 1: 23379 Segmentation fault      (core dumped) gdk-pixbuf-query-loaders --update-cache
    234:[2015-05-06 21:50] [ALPM] upgraded gtk2 (2.24.27-1 -> 2.24.27-2)
    

    And then those lines in the config are:

    [2015-05-03 00:18] [ALPM] installed vlc (2.2.1-2)
    [2015-05-03 00:18] [ALPM-SCRIPTLET] /tmp/alpm_QNlG2p/.INSTALL: line 1:  3503 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    [2015-05-03 00:18] [ALPM] transaction completed
    [2015-05-03 00:31] [ALPM] transaction started
    [2015-05-03 00:31] [ALPM] installed ttf-linux-libertine (5.3.0-3)
    [2015-05-03 00:31] [ALPM-SCRIPTLET] Couldn't determine full name for Khand-ExtraBold.ttf
    [2015-05-03 00:31] [ALPM-SCRIPTLET] Couldn't determine full name for Khand-Bold.ttf
    [2015-05-03 00:31] [ALPM-SCRIPTLET] Couldn't determine full name for Khand-Regular.ttf
    [2015-05-03 00:31] [ALPM-SCRIPTLET] Couldn't determine full name for Khand-Light.ttf
    [2015-05-03 00:31] [ALPM-SCRIPTLET] Couldn't determine full name for Khand-ExtraLight.ttf
    [2015-05-03 00:31] [ALPM-SCRIPTLET] Couldn't determine full name for Khand-SemiLight.ttf
    [2015-05-03 00:31] [ALPM-SCRIPTLET] Couldn't determine full name for Khand-SemiBold.ttf
    [2015-05-03 00:31] [ALPM-SCRIPTLET] Couldn't determine full name for Khand-Black.ttf
    [2015-05-03 00:31] [ALPM] transaction completed
    [2015-05-03 00:33] [ALPM] transaction started
    [2015-05-03 00:33] [ALPM] installed pygobject2-devel (2.28.6-11)
    [2015-05-03 00:33] [ALPM] installed python2-gobject2 (2.28.6-11)
    [2015-05-03 00:33] [ALPM] installed pygtk (2.24.0-5)
    [2015-05-03 00:33] [ALPM] installed libwmf (0.2.8.4-12)
    [2015-05-03 00:33] [ALPM-SCRIPTLET] /tmp/alpm_mELaD2/.INSTALL: line 1:  5873 Segmentation fault      (core dumped) gdk-pixbuf-query-loaders > etc/gtk-2.0/gdk-pixbuf.loaders
    [2015-05-03 00:33] [ALPM] installed ilmbase (2.1.0-1)
    [2015-05-03 00:33] [ALPM] installed openexr (2.1.0-1)
    [2015-05-03 00:33] [ALPM] installed gimp (2.8.14-1)
    [2015-05-03 00:33] [ALPM] transaction completed
    [2015-05-03 00:34] [ALPM] transaction started
    [2015-05-03 00:34] [ALPM] installed wxgtk2.8 (2.8.12.1-3)
    [2015-05-03 00:34] [ALPM] installed blas (3.5.0-1)
    [2015-05-03 00:34] [ALPM] installed lapack (3.5.0-1)
    [2015-05-03 00:34] [ALPM] installed python2-numpy (1.9.2-2)
    [2015-05-03 00:34] [ALPM] installed lv2 (1.12.0-1)
    [2015-05-03 00:34] [ALPM] installed serd (0.20.0-1)
    [2015-05-03 00:34] [ALPM] installed sord (0.12.2-1)
    [2015-05-03 00:34] [ALPM] installed sratom (0.4.6-1)
    [2015-05-03 00:34] [ALPM] installed lilv (0.20.0-1)
    [2015-05-03 00:34] [ALPM] installed vamp-plugin-sdk (2.5-2)
    [2015-05-03 00:34] [ALPM] installed sbsms (2.0.2-1)
    [2015-05-03 00:34] [ALPM] installed portsmf (228-1)
    [2015-05-03 00:34] [ALPM] installed audacity (2.1.0-1)
    [2015-05-03 00:34] [ALPM] transaction completed
    [2015-05-03 08:31] [ALPM] transaction started
    [2015-05-03 08:31] [ALPM] installed libgdiplus (3.12-1)
    [2015-05-03 08:31] [ALPM] installed mono (3.12.1-1)
    [2015-05-03 08:31] [ALPM] installed keepass (2.28-2)
    [2015-05-03 08:31] [ALPM] transaction completed
    [2015-05-03 08:35] [ALPM] transaction started
    [2015-05-03 08:35] [ALPM] removed keepass (2.28-2)
    [2015-05-03 08:35] [ALPM] installed keepassx (0.4.3-6)
    [2015-05-03 08:35] [ALPM] transaction completed
    [2015-05-03 08:37] [ALPM] transaction started
    [2015-05-03 08:37] [ALPM] installed guile1.8 (1.8.8-3)
    [2015-05-03 08:37] [ALPM] installed slib (3b4-1)
    [2015-05-03 08:37] [ALPM] installed goffice0.8 (0.8.17-3)
    [2015-05-03 08:37] [ALPM] installed libdbi (0.9.0-2)
    [2015-05-03 08:37] [ALPM] installed libdbi-drivers (0.9.0-2)
    [2015-05-03 08:37] [ALPM] installed libmariadbclient (10.0.17-2)
    [2015-05-03 08:37] [ALPM] installed postgresql-libs (9.4.1-1)
    [2015-05-03 08:37] [ALPM] installed gwenhywfar (4.13.1-2)
    [2015-05-03 08:37] [ALPM] installed ktoblzcheck (1.48-1)
    [2015-05-03 08:37] [ALPM] installed opensp (1.5.2-4)
    [2015-05-03 08:37] [ALPM] installed libxml++ (2.38.0-1)
    [2015-05-03 08:37] [ALPM] installed libofx (0.9.9-1)
    [2015-05-03 08:37] [ALPM] installed aqbanking (5.5.1-1)
    [2015-05-03 08:37] [ALPM] installed webkitgtk2 (2.4.8-2)
    [2015-05-03 08:37] [ALPM] installed gnucash (2.6.6-1)
    [2015-05-03 08:37] [ALPM-SCRIPTLET] 
    [2015-05-03 08:37] [ALPM-SCRIPTLET] (gconftool-2:3296): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
    [2015-05-03 08:37] [ALPM-SCRIPTLET] Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
    [2015-05-03 08:37] [ALPM] transaction completed
    [2015-05-03 08:54] [ALPM] transaction started
    [2015-05-03 08:54] [ALPM] removed lib32-mesa-libgl (10.5.4-1)
    [2015-05-03 08:54] [ALPM] installed lib32-nvidia-utils (349.16-1)
    [2015-05-03 08:54] [ALPM] installed lib32-nvidia-libgl (349.16-1)
    [2015-05-03 08:54] [ALPM] transaction completed
    [2015-05-03 12:12] [PACMAN] Running 'pacman --color auto -S --asdeps --needed extra/nasm'
    [2015-05-03 12:12] [ALPM] transaction started
    [2015-05-03 12:12] [ALPM] installed nasm (2.11.08-1)
    [2015-05-03 12:12] [ALPM] transaction completed
    [2015-05-03 12:16] [ALPM] transaction started
    [2015-05-03 12:16] [ALPM] upgraded perl-xml-libxml (2.0120-1 -> 2.0121-1)
    [2015-05-03 12:16] [ALPM] upgraded python-requests (2.6.2-1 -> 2.7.0-1)
    [2015-05-03 12:16] [ALPM] transaction completed
    [2015-05-03 12:32] [ALPM] transaction started
    [2015-05-03 12:32] [ALPM] reinstalled vlc (2.2.1-2)
    [2015-05-03 12:32] [ALPM-SCRIPTLET] /tmp/alpm_rGcw0N/.INSTALL: line 1: 23526 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    [2015-05-03 12:32] [ALPM] installed libva-vdpau-driver (0.7.4-2)
    [2015-05-03 12:32] [ALPM] installed libva-intel-driver (1.5.1-1)
    [2015-05-03 12:32] [ALPM] transaction completed
    [2015-05-03 12:38] [PACMAN] Running 'pacman -S vlc'
    [2015-05-03 12:38] [ALPM] transaction started
    [2015-05-03 12:38] [ALPM] reinstalled vlc (2.2.1-2)
    [2015-05-03 12:38] [ALPM-SCRIPTLET] /tmp/alpm_6LFldL/.INSTALL: line 1:  1408 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    [2015-05-03 12:38] [ALPM] transaction completed
    [2015-05-03 12:45] [PACMAN] Running 'pacman -S --force vlc'
    [2015-05-03 12:45] [ALPM] transaction started
    [2015-05-03 12:45] [ALPM] reinstalled vlc (2.2.1-2)
    [2015-05-03 12:45] [ALPM-SCRIPTLET] /tmp/alpm_rn55ie/.INSTALL: line 1:  1187 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    [2015-05-03 12:45] [ALPM] transaction completed
    [2015-05-03 12:46] [ALPM] transaction started
    [2015-05-03 12:46] [ALPM] removed vlc (2.2.1-2)
    [2015-05-03 12:46] [ALPM] transaction completed
    [2015-05-03 12:47] [PACMAN] Running 'pacman -S vlc'
    [2015-05-03 12:47] [ALPM] transaction started
    [2015-05-03 12:47] [ALPM] installed vlc (2.2.1-2)
    [2015-05-03 12:47] [ALPM-SCRIPTLET] /tmp/alpm_rZPuDA/.INSTALL: line 1:  1669 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    [2015-05-03 12:47] [ALPM] transaction completed
    [2015-05-04 16:15] [ALPM] transaction started
    [2015-05-04 16:15] [ALPM] upgraded cracklib (2.9.1-1 -> 2.9.4-1)
    [2015-05-04 16:15] [ALPM] upgraded gawk (4.1.1-1 -> 4.1.2-1)
    [2015-05-04 16:15] [ALPM] upgraded npth (1.1-1 -> 1.2-1)
    [2015-05-04 16:15] [ALPM] upgraded libksba (1.3.2-1 -> 1.3.3-1)
    [2015-05-04 16:15] [ALPM] upgraded libassuan (2.1.3-1 -> 2.2.0-1)
    [2015-05-04 16:15] [ALPM] upgraded pinentry (0.9.0-1 -> 0.9.1-1)
    [2015-05-04 16:15] [ALPM] upgraded gnupg (2.1.3-2 -> 2.1.3-3)
    [2015-05-04 16:15] [ALPM] upgraded gpgme (1.5.3-1 -> 1.5.4-1)
    [2015-05-04 16:15] [ALPM] upgraded lib32-libpciaccess (0.13.3-1 -> 0.13.4-1)
    [2015-05-04 16:15] [ALPM] upgraded libedit (20141030_3.1-1 -> 20150325_3.1-1)
    [2015-05-04 16:15] [ALPM] upgraded pciutils (3.3.0-1 -> 3.3.1-1)
    [2015-05-04 16:15] [ALPM] upgraded s-nail (14.7.11-1 -> 14.8.0-1)
    [2015-05-04 16:15] [ALPM] transaction completed
    [2015-05-04 18:48] [ALPM] transaction started
    [2015-05-04 18:48] [ALPM] installed simplescreenrecorder (0.3.3-1)
    [2015-05-04 18:48] [ALPM] transaction completed
    [2015-05-05 05:50] [ALPM] transaction started
    [2015-05-05 05:50] [ALPM] upgraded numix-frost-themes (1.3-4 -> 1.7-1)
    [2015-05-05 05:50] [ALPM] upgraded numix-icon-theme (0.r616.3267247-1 -> 0.r627.5cf3220-1)
    [2015-05-05 05:50] [ALPM] transaction completed
    [2015-05-05 15:07] [ALPM] transaction started
    [2015-05-05 15:07] [ALPM] upgraded dhcpcd (6.8.1-1 -> 6.8.2-1)
    [2015-05-05 15:07] [ALPM] upgraded libnm-glib (1.0.0-2 -> 1.0.2-1)
    [2015-05-05 15:07] [ALPM] upgraded nm-connection-editor (1.0.0-2 -> 1.0.2-1)
    [2015-05-05 15:07] [ALPM] upgraded network-manager-applet (1.0.0-2 -> 1.0.2-1)
    [2015-05-05 15:07] [ALPM] upgraded networkmanager (1.0.0-2 -> 1.0.2-1)
    [2015-05-05 15:07] [ALPM] upgraded networkmanager-openvpn (1.0.0-2 -> 1.0.2-1)
    [2015-05-05 15:07] [ALPM] upgraded networkmanager-pptp (1.0.0-1 -> 1.0.2-1)
    [2015-05-05 15:07] [ALPM] transaction completed
    [2015-05-05 15:21] [PACMAN] Running 'pacman -S gutenprint'
    [2015-05-05 15:21] [ALPM] transaction started
    [2015-05-05 15:21] [ALPM] installed gutenprint (5.2.10-1)
    [2015-05-05 15:21] [ALPM-SCRIPTLET] >>please run /usr/bin/cups-genppdupdate
    [2015-05-05 15:21] [ALPM-SCRIPTLET] >>and restart cups deamon
    [2015-05-05 15:21] [ALPM] transaction completed
    [2015-05-06 20:34] [PACMAN] Running 'pacman --color auto -U /tmp/yaourt-tmp-eadword/PKGDEST.BTr/alsaequal-0.6-12-x86_64.pkg.tar.xz'
    [2015-05-06 20:34] [ALPM] transaction started
    [2015-05-06 20:34] [ALPM] installed alsaequal (0.6-12)
    [2015-05-06 20:34] [ALPM-SCRIPTLET] ==> See http://www.thedigitalmachine.net/alsaequal.html and the Arch ALSA wiki
    [2015-05-06 20:34] [ALPM-SCRIPTLET]     page for configuration instructions.
    [2015-05-06 20:34] [ALPM] transaction completed
    [2015-05-06 20:38] [ALPM] transaction started
    [2015-05-06 20:38] [ALPM] removed alsaequal (0.6-12)
    [2015-05-06 20:38] [ALPM] transaction completed
    [2015-05-06 20:39] [PACMAN] Running 'pacman --color auto -S --asdeps --needed extra/swh-plugins'
    [2015-05-06 20:39] [ALPM] transaction started
    [2015-05-06 20:39] [ALPM] installed swh-plugins (0.4.15-6)
    [2015-05-06 20:39] [ALPM] transaction completed
    [2015-05-06 20:39] [PACMAN] Running 'pacman --color auto -U /tmp/yaourt-tmp-eadword/PKGDEST.Pda/pulseaudio-equalizer-2.7.0.2-4-x86_64.pkg.tar.xz'
    [2015-05-06 20:39] [ALPM] transaction started
    [2015-05-06 20:39] [ALPM] installed pulseaudio-equalizer (2.7.0.2-4)
    [2015-05-06 20:39] [ALPM] transaction completed
    [2015-05-06 21:50] [ALPM] transaction started
    [2015-05-06 21:50] [ALPM] upgraded gtk-update-icon-cache (2.24.27-1 -> 2.24.27-2)
    [2015-05-06 21:50] [ALPM] upgraded librsvg (1:2.40.9-1 -> 1:2.40.9-2)
    [2015-05-06 21:50] [ALPM-SCRIPTLET] /tmp/alpm_oZ8pgh/.INSTALL: line 1: 23379 Segmentation fault      (core dumped) gdk-pixbuf-query-loaders --update-cache
    [2015-05-06 21:50] [ALPM] upgraded adwaita-icon-theme (3.16.0-1 -> 3.16.0-2)
    [2015-05-06 21:50] [ALPM] upgraded git (2.3.7-1 -> 2.4.0-1)
    [2015-05-06 21:50] [ALPM] upgraded gtk2 (2.24.27-1 -> 2.24.27-2)
    
  • Quick solution…

    1. Update system
    2. Install SMplayer

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • @Brian-Flowers @Eadword ,

    What’s the output of uname -r? Also, how long has it been since your last reboot?

  • I’ve updated my system five times and performed many reboots since this issue started. Lastest update was 9 days ago; last reboot was yesterday.

    uname -r: 4.0.5-1-ARCH

    And Eadword, I’m pretty sure it’s not just the Nvidia drivers – it worked fine on my system, using the NVidia drivers, until May 12th. I’ve had the Nvidia drivers installed on this system for more than a year. Unfortunately in your case it looks like you never had a clean install of these packages to begin with, so I’m not sure now that comparing the pacman.log files is going to help. It might still be worth a shot unless someone else offers a better suggestion though. But I’d need lines 0-70; 70 to 234 is just between two segfaults.

  • @lots.0.logs
    I am getting 4.0.5-1-ARCH as well and just restarted within the past few hours.

    And here are lines 0-70.

    [2015-05-02 21:47] [ALPM] transaction started
    [2015-05-02 21:47] [ALPM] removed mesa-libgl (10.5.4-1)
    [2015-05-02 21:47] [ALPM] installed nvidia-libgl (349.16-1)
    [2015-05-02 21:47] [ALPM] installed nvidia-utils (349.16-1)
    [2015-05-02 21:47] [ALPM-SCRIPTLET] If you run into trouble with CUDA not being available, run nvidia-modprobe first.
    [2015-05-02 21:47] [ALPM] installed nvidia (349.16-2)
    [2015-05-02 21:47] [ALPM-SCRIPTLET] In order to use nvidia module, reboot the system.
    [2015-05-02 21:47] [ALPM] transaction completed
    [2015-05-02 21:59] [ALPM] transaction started
    [2015-05-02 21:59] [ALPM] transaction failed
    [2015-05-02 21:59] [ALPM] transaction started
    [2015-05-02 21:59] [ALPM] transaction failed
    [2015-05-02 22:01] [ALPM] transaction started
    [2015-05-02 22:01] [ALPM] installed libmng (2.0.2-3)
    [2015-05-02 22:01] [ALPM] installed qt4 (4.8.6-5)
    [2015-05-02 22:01] [ALPM] installed lsb-release (1.4-14)
    [2015-05-02 22:01] [ALPM] installed mumble (1.2.8-3)
    [2015-05-02 22:01] [ALPM] transaction completed
    [2015-05-02 22:21] [PACMAN] Running 'pacman --color auto -S --asdeps --needed extra/qtwebkit'
    [2015-05-02 22:21] [ALPM] transaction started
    [2015-05-02 22:21] [ALPM] installed qtwebkit (2.3.4-1)
    [2015-05-02 22:21] [ALPM] transaction completed
    [2015-05-02 22:21] [PACMAN] Running 'pacman --color auto -U --asdeps /tmp/yaourt-tmp-eadword/PKGDEST.Icv/libgcrypt15-1.5.4-4-any.pkg.tar.xz'
    [2015-05-02 22:22] [ALPM] transaction started
    [2015-05-02 22:22] [ALPM] installed libgcrypt15 (1.5.4-4)
    [2015-05-02 22:22] [ALPM] transaction completed
    [2015-05-02 22:23] [PACMAN] Running 'pacman --color auto -U /tmp/yaourt-tmp-eadword/PKGDEST.VWy/spotify-0.9.17.1-1-x86_64.pkg.tar.xz'
    [2015-05-02 22:23] [ALPM] transaction started
    [2015-05-02 22:23] [ALPM] installed spotify (0.9.17.1-1)
    [2015-05-02 22:23] [ALPM] transaction completed
    [2015-05-02 22:25] [ALPM] transaction started
    [2015-05-02 22:25] [ALPM] installed gtkmm (2.24.4-1)
    [2015-05-02 22:25] [ALPM] installed gparted (0.22.0-1)
    [2015-05-02 22:25] [ALPM] transaction completed
    [2015-05-02 23:07] [ALPM] transaction started
    [2015-05-02 23:07] [ALPM] installed libgit2 (1:0.22.1-1)
    [2015-05-02 23:07] [ALPM] installed libgit2-glib (0.22.6-1)
    [2015-05-02 23:07] [ALPM] installed gtkspell3 (3.0.7-1)
    [2015-05-02 23:07] [ALPM] installed gitg (3.16.1-1)
    [2015-05-02 23:07] [ALPM] transaction completed
    [2015-05-02 23:56] [PACMAN] Running 'pacman -Syu'
    [2015-05-02 23:56] [PACMAN] synchronizing package lists
    [2015-05-02 23:56] [PACMAN] starting full system upgrade
    [2015-05-02 23:56] [PACMAN] Running 'pacman -Sys'
    [2015-05-02 23:56] [PACMAN] synchronizing package lists
    [2015-05-03 00:01] [PACMAN] Running 'pacman -S steam'
    [2015-05-03 00:01] [ALPM] transaction started
    [2015-05-03 00:01] [ALPM] installed steam (1.0.0.49-3)
    [2015-05-03 00:01] [ALPM-SCRIPTLET] if you are running x86_64, you need the lib32 opt depends for your driver
    [2015-05-03 00:01] [ALPM-SCRIPTLET] if you are having problems with the steam license, remove .steam and .local/share/Steam
    [2015-05-03 00:01] [ALPM] transaction completed
    [2015-05-03 00:18] [PACMAN] Running 'pacman --color auto -U /tmp/yaourt-tmp-eadword/PKGDEST.hs5/google-chrome-beta-43.0.2357.45-1-x86_64.pkg.tar.xz'
    [2015-05-03 00:18] [ALPM] transaction started
    [2015-05-03 00:18] [ALPM] installed google-chrome-beta (43.0.2357.45-1)
    [2015-05-03 00:18] [ALPM-SCRIPTLET] (B==>(B Updating desktop MIME database...(B
    [2015-05-03 00:18] [ALPM-SCRIPTLET] (B==>(B Updating icon cache..(B
    [2015-05-03 00:18] [ALPM-SCRIPTLET] (B==>(B NOTE:(B The launcher is called: 'google-chrome-beta'(B
    [2015-05-03 00:18] [ALPM] transaction completed
    [2015-05-03 00:18] [ALPM] transaction started
    [2015-05-03 00:18] [ALPM] installed libdvbpsi (1:1.1.2-1)
    [2015-05-03 00:18] [ALPM] installed sdl_image (1.2.12-3)
    [2015-05-03 00:18] [ALPM] installed libkate (0.4.1-5)
    [2015-05-03 00:18] [ALPM] installed libtiger (0.3.4-4)
    [2015-05-03 00:18] [ALPM] installed libebml (1.3.1-1)
    [2015-05-03 00:18] [ALPM] installed libmatroska (1.4.2-1)
    [2015-05-03 00:18] [ALPM] installed zvbi (0.2.35-1)
    [2015-05-03 00:18] [ALPM] installed libupnp (1.6.19-1)
    [2015-05-03 00:18] [ALPM] installed xcb-util-keysyms (0.4.0-1)
    [2015-05-03 00:18] [ALPM] installed libtar (1.2.20-2)
    [2015-05-03 00:18] [ALPM] installed vlc (2.2.1-2)
    [2015-05-03 00:18] [ALPM-SCRIPTLET] /tmp/alpm_QNlG2p/.INSTALL: line 1:  3503 Segmentation fault      (core dumped) usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
    
  • OK, so after updating to try and resolve VLC’s problems and also installing SMplayer: I just found out that I am no longer able to run cinnamon-settings:

    [[email protected] ~]$ cinnamon-settings
    
    ** (cinnamon-settings.py:1102): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
    Traceback (most recent call last):
      File "/usr/lib/cinnamon-settings/cinnamon-settings.py", line 38, in <module>
        modules = map(__import__, mod_files)
      File "/usr/lib/cinnamon-settings/modules/cs_applets.py", line 3, in <module>
        from ExtensionCore import ExtensionSidePage
      File "/usr/lib/cinnamon-settings/bin/ExtensionCore.py", line 29, in <module>
        curr_ver = subprocess.check_output(["cinnamon", "--version"]).splitlines()[0].split(" ")[1]
      File "/usr/lib/python2.7/subprocess.py", line 573, in check_output
        raise CalledProcessError(retcode, cmd, output=output)
    subprocess.CalledProcessError: Command '['cinnamon', '--version']' returned non-zero exit status -11
    Segmentation fault (core dumped)
    
segfault6 vlc13 Posts 33Views 11103
Log in to reply