• LightDM/Gnome lock on suspend


    Hi,

    (How) is it possible to automatically lock the screen when suspending to ram with the systemd-command using the lightdm gnome-screensaver?

    Or alternatively, what is the best way to automatically start xscreensaver and do it like described here: https://wiki.archlinux.org/index.php/Xscreensaver#Automatically_lock_when_suspending.2Fsleeping.2Fhibernating

  • Did you install Antergos recently? If so it should be configured for you. All you have to do is enable the options in the Light Locker Settings application. Let me know if you didn’t install recently and I will find the post where I explain how to set it up manually. Cheers!

  • thanks for the reply.
    how recently do you mean? I installed Antergos 6 weeks ago.

  • Here is the post that lists the steps to configure the lock screen as it now comes by default on new installs:

    http://forum.antergos.com/topic/1944/bug-unable-to-lock-autolock-antergos-gnome-on-alienware-m11x-r2/12?page=2

    Cheers!

  • @lots.0.logs you mean the method from post 12 in that thread?

    in trying to use a workaround something is weird: calling ‘dm-tool lock && systemctl suspend’ from a terminal works basically as intended, but triggering it via a keyboard shortcut in gnome doesn’t. Why is that?

  • I found that what was wrong with the shortcut I was trying to use was that commands attached to shortcuts via the gnome preferences don’t get passed to a shell automatically, so shell operators won’t work unless a shell is called like this:
    sh -c 'dm-tool lock & systemctl suspend'

gnome322 lightdm127 suspend45 systemd30 screensaver12 Posts 6Views 3589
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.