• lightdm+fresh install=white screen


    I got the latest 32 bit minimal iso and installed to an acer c720p. After reboot the screen goes white and stays that way, can’t click past it or anything. The mouse cursor is still there but thats it. Here are some logs, although this is the first time I’ve posted this kind of information so if I’m missing anything let me know.
    logs.tar

  • It does not appear that your system is using the default configuration from our installer like your post implies. What configuration changes did you make prior to this issue? I see you are using GDM and Wayland which is not considered to be production-ready. I recommend you use the traditional and only supported method which is X-only (no wayland).

    Cheers!

  • I installed gdm because I didnt know how else to access the file system and make the logs i needed. I only have a limited understanding when it comes to using the terminal so for me getting past the login screen and into the desktop environment was the only way I knew how to even post what I did

  • Sorry, I didn’t see any lightdm info in the journal when I first checked. Upon further review I found that it is segfaulting (crashing). Have you updated to the latest version of the package. It was updated yesterday, or the day before (not sure which). Do this to be sure:

    sudo pacman -Syyu
    
  • It is up to date. If I re enable lightdm and uninstall gdm and wayland is there a way I can get the logs? Using pacman in the terminal is one thing but navigating and moving things in the file system using the terminal sounds like my worst nightmare.

  • Sorry I misread your last post. Never mind about what I wrote regarding the logs, but I am running all the latest packages.

  • I was not able to find anything useful related to this bug. I’m afraid you’ll have to use an alternate display manager until it gets fixed upstream. One thing you could try is adding the following to your kernel boot command (Press e when grub starts):

    i915.semaphores=1
    
  • Thanks for trying. I can’t be the only person having this issue but I am having a hard time finding info on this bug. It wouldn’t be so bad if gdm was better.

  • @slevin said:

    Thanks for trying. I can’t be the only person having this issue but I am having a hard time finding info on this bug. It wouldn’t be so bad if gdm was better.

    You are not – I believe there are a number of threads noting this problem. lxdm works fine for me.

  • start tty ( ctrl+fn+alt+f2 or ctrl+fn+alt+f3 or ctrl+ alt+f2 or ctrl+alt+f3

    sudo pacman -Syy
    yaourt -S lightdm-crowd-greeter
    sudo nano /etc/lightdm/lightdm.con

    .-------replace

    greeter-session=lightdm-webkit2-greeter

    -----------with

    greeter-session=lightdm-crowd-greeter

    --------or anything installed with yaourt, example

    yaourt -S lightdm-another-gtk-greeter
    yaourt -S lightdm-webkit-greeter
    yaourt -S lightdm-crowd-greeter
    yaourt -S lightdm-unity-greeter
    yaourt -S lightdm-pantheon-greeter

    save changes and type

    sudo systemctl enable lightdm
    sudo systemctl start lightdm

  • I had problems with lightdm aswell, they started to apear after screen lock, i wasnt able to fix it, i had to switch to gdm and not regretting it at all, if you need help i can write short instruction how to do so.

install78 lightdm97 Posts 11Views 3422
Log in to reply