• GDM blank screen after updates and no command prompt


    Hi everyone, i am having on my Toshiba Satellite with nvidia geforce 6150se nforce 430 graphic card and Antergos GNOME exactly the same blank screen problem described here: http://forum.antergos.com/topic/1897/blank-white-screen-after-update

    The problem is, I cant manage to get a command line to retrieve the system logs or trying to work on gdm with the solution described above. Pressing CTRL ALT F2 makes nothing at all, the screen remains black, tough I can still reboot the system with CTRL ALT DEL.

    Does anyone knows how could I solve this issue? I’m a newbie and my only idea was to format and install everything again from scratch, but that seems quite an unpleasant idea in this precise moment…

    Thanks in advance for your comments

  • By the way, I’ve already noticed that it isn’t anything related to the key “Fn” while trying to get F2…

  • Hi,

    Try replacing the quiet argument in the kernel boot command with the following (Press e when grub appears):

    systemd.unit=multi-user.target
    

    You should be able to log in. Only your logs from the previous boots will be helpful (because that’s when the error occurred) Let me know if you have any questions.

  • @lots.0.logs Thanks for your suggestion! I’ve replaced the line “quiet” with “systemd.unit=multi-user.target”, but although now the boot process now shows more info than before, it ends up anyway in a blank screen :’(

  • Hmmm…Are there any clues as to what the problem might be in the output that appears on the screen? Try emergency mode instead of multi-user: systemd.unit=emergency.target You won’t have network access but you will at least be able to access the logs from previous failed boot attempts like this (0 is the current boot, 1 is the last boot, 2 is the boot before last, etc):

    journalctl -b -1
    
  • @lots.0.logs said:

    Hmmm…Are there any clues as to what the problem might be in the output that appears on the screen? Try emergency mode instead of multi-user: systemd.unit=emergency.target You won’t have network access but you will at least be able to access the logs from previous failed boot attempts like this (0 is the current boot, 1 is the last boot, 2 is the boot before last, etc):

    journalctl -b -1
    

    OK, thanks! That worked fine and I was able to export the last two systemd journal logs to my /tmp folder, but the problem is that now I can’t retrieve them to share it here, because I’m running the live media and can’t mount my encrypted system hard disk because I’m been asked for the password for the live user “antergos”. I couldn’t find it in the forums and I’ve already attempted it with “antergos”, “root”, “liveuser”, etc., with no success at all. Any ideas?

  • There is not a password actually. You will have to mount the drive from the command line using sudo so that it doesn’t ask you for a password.

  • Understood, thanks. Now I could manage to retrieve the logs and here they are. I hope it can help!
    journal logs.tar

  • @lots.0.logs I can’t find any clue during boot process of what can possibly cause this. I had access to the journalctl logs but there’s so much info there that I don’t really understand (I’ve shared them here a couple of days ago). Can you thing of anything else that I can try, at least until that logs get checked by someone who can understand them better than me? I’ll wait for comments, tanks!

  • @maxime said:

    @lots.0.logs I can’t find any clue during boot process of what can possibly cause this. I had access to the journalctl logs but there’s so much info there that I don’t really understand (I’ve shared them here a couple of days ago). Can you thing of anything else that I can try, at least until that logs get checked by someone who can understand them better than me? I’ll wait for comments, tanks!

    Here an important update: I’ve just discovered that I can boot successfully with a second display connected, tough the main display still won’t work at all shortly after GRUB appears (and doesn’t work in any of the different combinations like mirror or extended). A new system update hasn’t solved it, too. ¿Can it be the video drivers?

  • I think I had the same issue like you after a system crash, solved it like that:

    1. Edit your kernel boot command and replace the quiet argument or *systemd.unit=multi-user.target *argument with 3 for runlevel three.
      The system is then asking you for your root password. Simply login.
    2. Disable your display manger like that: systemctl disable gdm or systemctl disable lightdm.
    3. Reboot
    4. Now when the system is prompting you login with your username and password.
    5. Reinstall xorg-server-xwayland xorg-server and gdm (sudo pacman -S xorg-server-xwayland xorg-server gdm)
    6. Now my system was telling me that serveral files were already existing, somehow it “forgot” about them at the crash.
    7. Solved it like that sudo pacman -S xorg-server-xwayland xorg-server gdm --force (Attention: Do not use the force command if you’r not knowing what you want to do. Never! Ever!
    8. Re-enable your display manager systemctl enable gdm
    9. Reboot.

    Hope I could help.

  • @Christoph-Berliner Thanks a lot for the detailed anwser! I was lucky to solve it just a couple of days prior, switching to propietary drivers for my card. It seems like everything got messed up after the latest update of Xorg server… I think this can be already marked as solved for me.

gnome229 update45 gdm33 boot163 Posts 12Views 3390
Log in to reply