• grub still looking for broken iSSD with new installation on HDD


    This is my first time posting to this forum so I apologise if I do anything wrong, please just let me know and ill update asap.

    I have a Asus Zenbook UX32VD. This laptop has a 500GB HDD and a built in 24GB iSSD (not sure what the i is for).

    Since I first got it three years ago I have been installing various linux distributions on the iSSD and mounting /home on the HDD. Currently I use Antergos. This worked very well until the iSSD broke (there are many complaints about this). The problem appears to be something with the soldering, in any case, the iSDD cannot be detected (gparted, bios, etc.). When booting this gives me an error:

    error: no such device: 00ea25be-ec8a-4b22-87d2-8ee9c797f273
    Entering rescue mode...
    grub rescue> _
    

    The laptop is quite old and I dont plan to invest much in fixing the iSSD.

    On the HDD the first partition was a 8GB swap partition, followed by the 480 GB home partition. I shrank the swap partition at the beginning to make room for a 300 MB efi partition (at the beginning). I also shrank the home partition by 50 GB (at the end) in order to create a root partition. On this I installed a new Antergos installation. The partitions on the HDD are now (in order): EFI, SWAP, home, root.

    The installation ran fine and ended successfully, however upon rebooting I get the same error (with the same UUID). I have tried chrooting into the new installation and rebuilding grub but this does not seem to work.

    I checked the grub.cfg file on my new EFI partition and the only UUID it contains is this one (i.e. the new and correct one):

    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos3 --hint-efi=hd0,msdos3 --hint-baremetal=ahci0,msdos3  e93abfe5-bfab-4f2b-a90f-6bfa11576fa7
    else
      search --no-floppy --fs-uuid --set=root e93abfe5-bfab-4f2b-a90f-6bfa11576fa7
    

    How can I get grub to find my new installation and stop looking for the iSDD?

    Many thanks in advance

  • Hi,

    Check the boot device order in your BIOS settings. Make sure that your HDD is listed before the iSSD. Let me know if that helps!

  • @lots.0.logs thanks, the iSSD isn’t in bios any more, I believe the connection physically broke, this is hard to check because its welded on the motherboard, but from what I read online this seems to be very common.

  • It sounds like your UEFI firmware is still looking for the other drive. Go through the available options for managing your UEFI bootloader. Find the devices and ensure that your HDD is first. Let me know how it goes. Cheers!

  • @lots.0.logs thanks, this sounds like something promising, but how do I exactly do that. go through the UEFI bootloader options?

  • @lots.0.logs I just installed again with gummiboot in stead of grub2, same issue. lastly, when I load the live usb (may-image, testing) it seems to be looking for something for a long time (ata2) and then says giving up.

grub69 Posts 6Views 1615
Log in to reply