• Cheese Fails


    As of late, if I try to take a photo with my webcam using Cheese, it fails. When the app first opens, the picture is displayed from the camera. But when I take the photo, it gives and error that “there was an error playing video from the camera.” I ran cheese from terminal to get more info as to what is happening, and here is the output when the failure happens:

    (cheese:4325): cheese-WARNING **: Device ‘/dev/video0’ is busy: gstv4l2object.c(2838): gst_v4l2_object_set_format (): /GstCameraBin:camerabin/GstWrapperCameraBinSrc:camera_source/GstBin:bin35/GstV4l2Src:video_source:
    Call to S_FMT failed for YU12 @ 1280x720: Device or resource busy

    Anyone able to duplicate this problem? Anyone able to help troubleshoot? I know this issue is not Antergos specific, but since we’re all friends here 😉 It used to work just fine, and I have no idea what introduced the failure.

    Thanks

  • @Myk-Robinson

    Cheese is actually kind of crap, I would suggest replacing it with guvcview.

    https://www.archlinux.org/packages/community/x86_64/guvcview/

    Personal: http://michaeltunnell.com
    Business: http://visuex.com

  • @MichaelTunnell check this:

    [[email protected] ~]$ guvcview
    GUVCVIEW: couldn’t open /home/myk/.config/guvcview2/video0 for read: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    ALSA lib pcm_dsnoop.c:614:(snd_pcm_dsnoop_open) unable to open slave
    ALSA lib pcm_dmix.c:1024:(snd_pcm_dmix_open) unable to open slave
    ALSA lib pcm.c:2267:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
    ALSA lib pcm.c:2267:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
    ALSA lib pcm.c:2267:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
    ALSA lib pcm_dmix.c:1024:(snd_pcm_dmix_open) unable to open slave
    connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
    attempt to connect to server failed

    ** (guvcview:2259): WARNING **: Couldn’t register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
    Segmentation fault (core dumped)

  • Looks like it works if I run it with guvcview -d /dev/video0

    Now to figure out how to make it do that by default

Posts 4Views 1804
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.