• Nautilus - can't mount USB drive and doesn't show disks by label


    Don’t know how to trace back when it happened but as the Subject says, my Nautilus is having some problems and as much as i try to find the solution in the wiki i wasn’t able to find solutions for my problems, so any help would be welcomed.

    Problem1:
    Until a few weeks ago my “nautilus” used to show disk drives by name ie: ComicsVault instead of sdf1. when it worked as i wanted it to, fstab was listing disk by UUID and nautilus was showing disks by name as want it.
    I don’t know what changed but it no longer works, i change fstab to show diks by “Label=”’ it still doesn’t work.

    As a result of this unwanted change by shared folder association in virtualbox stop working.

    Problem2:
    Also as aresult of this change i’am unable to mount/read/write usb flash drives

    If i do lsusb in a terminal the result is
    us 008 Device 004: ID 0951:1624 Kingston Technology DataTraveler G2

    when itry

    [email protected] ~> udiskie -t -0
    
    ** (udiskie:9365): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
    mounted /org/freedesktop/UDisks/devices/sdg1 on /media/multisystem
    failed to mount /org/freedesktop/UDisks/devices/sdg: GDBus.Error:org.freedesktop.UDisks.Error.FilesystemDriverMissing: Error mounting: mount: /dev/sdg is write-protected, mounting read-only
    mount: /dev/sdg is already mounted or /media/ARCH_201408 busy
    
    operation failed for device: /org/freedesktop/UDisks/devices/sdg
    

    this result shows up and my usb drive show in nautilus even thought i cannot acess it

    What am i doing wrong?
    What am i missing? Am i missing something simple and obvious?

    Thanks for your help
    I have already posted a similar question to this one is arch forums , as of today 54 persons viewed the question but i still don’t have an answer., so i posted it again here.

  • I’m taking a stab in the dark here, but try doing this:

    sudo chown -R  nuno:users /home/nuno/.local/share/gvfs-metadata
    

    If the chisel (above) doesnt help, try a sledge hammer :wink:

    sudo chown -R  nuno:users /home/nuno/
    
  • Sorry.
    I tried it but didn’t work out.
    Thank you anyway

  • There was an update to all gnome core packages recently. Be sure your system is fully updated. If it still isnt working, I would need to see your journal and session logs.

    Cheers!

  • Hi
    I am soory it tokk so long to reply but i haven’t been able to acess my pc.
    Sometime ago (during this last week) after some

    sudo pacman -Syu
    

    Nautilus started working properly, identifying disks by label as a wanted it it to and recognizing usb pens.
    Don’t have the knowledge to search logs and see what changed but right now it’s working. I was on the verge to switch back to ubuntu or maybe to try to configure my LMDE2 properly and use it as my main distro.
    Anyhow thanks for your help.
    How do i mark this thread as solved?

Posts 5Views 1830
Log in to reply