• Touchpad always clicking in some applications


    I’m having a problem where some programs register the touchpad on my laptop as always clicking, which makes them quite unusable.

    Some of the programs where I remember this problem happening:

    • gedit
    • Nemo
    • Document Viewer
    • Wireshark

    Most applications work just as expected. Some examples of programs that work fine are Firefox, TeXstudio, and Terminal.

    This only happens when I am using my touchpad (which is one of those touchpads where the entire thing is a big button) and does not happen when I have a mouse plugged in. My laptop is an Acer Aspire E5-571-37SY. I am using Cinnamon.

    I wasn’t sure which logs to include, so I included all of the ones listed in the HOW TO post, except for the Xorg ones because they were above the forum size limit. logs.tar

    Thanks for the help! Let me know if I should include any more info.

  • @morganfshirley said:

    E5-571-37SY

    Hi,

    What’s the output of the following command?

    sudo xinput -list
    
  • Thanks for the response, and sorry for the late reply. Here is the output:

    ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
    ⎜   ↳ ELAN0501:00 04F3:300B UNKNOWN           	id=11	[slave  pointer  (2)]
    ⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
        ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
        ↳ Power Button                            	id=6	[slave  keyboard (3)]
        ↳ Video Bus                               	id=7	[slave  keyboard (3)]
        ↳ Power Button                            	id=8	[slave  keyboard (3)]
        ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
        ↳ HD WebCam                               	id=10	[slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard            	id=12	[slave  keyboard (3)]
        ↳ Acer WMI hotkeys                        	id=13	[slave  keyboard (3)]
  • @morganfshirley said:

    ELAN0501:00 04F3:300B UNKNOWN

    Try adding the following options to /etc/X11/xorg.conf.d/50-synaptics.conf

    Option "ClickPad"         "true"
    Option "EmulateMidButtonTime" "0"
    

    If that doesnt help try installing this package from the aur: elantech-asustouchpad-dkms

  • The problem seems to be fixed, thanks!

    EDIT: The problem was fixed for a while, but then it started happening again after some time using Document Viewer.

touchpad31 Posts 5Views 1155
Log in to reply