• Shadow.service failure - help fixing


    Looks like I broke something under the hood when I tried to install Sickbeard not too long ago. My machine boots up and works just fine, but I started noticing an error during the boot process. I tried tracing the error and it seems to be related to shadow.service and a user or group that was created when sickbeard was installed. At any rate, this seems to be the pertinent information:

    *-- Subject: Unit shadow.service has begun start-up
    – Defined-By: systemd
    – Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel

    – Unit shadow.service has begun starting up.
    May 12 19:00:10 atergos pwck[1674]: user ‘sickbeard’: directory ‘/var/lib/sickbeard’ does not exist
    May 12 19:00:10 atergos pwck[1674]: pwck: no changes
    May 12 19:00:10 atergos systemd[1]: shadow.service: main process exited, code=exited, status=2/INVALIDARGUMENT
    May 12 19:00:10 atergos systemd[1]: Failed to start Verify integrity of password and group files.
    – Subject: Unit shadow.service has failed
    – Defined-By: systemd
    – Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel

    – Unit shadow.service has failed.*

    Little help rectifying the situation?
    Thanks

  • @Myk-Robinson pwck validates /etc/passwd and /etc/shadow. Best guess is that sickbeard exists in /etc/passwd with /var/lib/sickbeard as home directory. If you don’t use sickbeard, you can use userdel or remove the offending lines from the two files.

  • @axaxs Thanks for that. I used the userdel command to remove any leftover traces of the sickbeard user, and the error is gone now.

Posts 3Views 1041
Log in to reply