• BUG: Trying to resize a snapped window (such as Chrome or Firefox) results in Gnome Shell crash.


    Hi guys, I’ve getting alot of crashes and I couldn’t figure out what it was until today.

    I’ve noticed that if my Chrome or Firefox are snapped to half the screen in Gnome Shell and I try to resize them while snapped, Gnome Shell crashes. I tried to reproduce this with other apps such as gedit, libre office, gparted, terminal but it seems that only firefox and chrome offer you the choice of resizing snapped windows. The others don’t offer that choice.

    I’m on Gnome Shell and currently using GDM. I have the nVidia 340,xx drivers but the nouveau drivers are even worst (at least with nvidia the shell restarts, with nouveau, it would freeze altogetger and I’d have to reboot from terminal via ctrl alt f3).

    What logs do you need? I can’t reproduce this 100% of the time.

  • Most likely a graphics glitch.

    Does it happen with all browsers?
    Try Gnome’s deafult Epiphany and also try Vivaldi(TP3).

    I’m on Gnome too and I don’t face any such issue, also, gedit, gparted, terminal all these allow me to resize snapped windows.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • I just tried resizing non snapped windows and they’re crashing too. All Windows, of all apps. I think that maybe this bug must have been introduced with with one of the new updates.

    I’ve turned off all the extension and I still get the same issue.

    You on GDM or lightDM yash?

  • me on GDM

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • You on nVidia or AMD?

  • I had a kde cursor theme on. I switched back to the default adwaita and the crashes stopped. Weeeeiiirrrrrdddd. Is this a bug or is there some incompatibility between the cursor theme standards between gnome shell and kde? I’ve used imported cursor themes before. Never with such issues.

  • weeeiiirrrddddd, wow!
    Change with some other cursor theme if Adwaita is boring.

    and I’m on AMD.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • On G3 using Nvidia drivers on one & generic (both Nvidia cards) the other. Both have had freeze followed by ‘oops’ & logout while using Firefox yesterday & today.

  • @Uzi Are you using a custom cursor as well or are you using Adwaita?

  • @Fadi-R The standard Adwaita

  • It’s a weird bug. Try switching the mouse cursor theme to something else. Maybe the bug will go away.

window snapping1 gdm33 gnomeshell3 Posts 11Views 2473
Log in to reply