• Gnome slow after some changes


    After update pcre (8.36-2 -> 8.37-1), openexr (2.1.0-1 -> 2.2.0-1), ilmbase (2.1.0-1 -> 2.2.0-1), libtasn1 (4.4-1 -> 4.5-1) Gnome is very slow
    Anyone could tell me how to reverse the upgrade from previous versions?

    EDIT:
    I could reverse updates with pacman -U package searching the pacman cache… but this does not fix the problem…
    Then I remembered that I had previously installed libappindicator-gtk3 and also uninstall it… but does not solve the delay.
    These dependencies are required to libappindicator-gtk3:
    libdbusmenu-gtk3
    libindicator-gtk3
    dbus-glib
    gobject-introspection
    gtk-sharp-2
    libdbusmenu-gtk2
    libdbusmenu-gtk3
    libindicator-gtk2
    libindicator-gtk3
    perl-xml-libxml
    pygtk
    vala
    Finally, remove previously installed jre sun… the delay is still there.
    Those were the only ones changes you make to my installation of antergos in the last hours.
    any idea what could be happening?

  • System load, logging, gnome dash, firefox and everything to delay … I’m using the default nouveau drivers for my nvidia originally installed without any subsequent changes

  • @internauta2000 said:

    I’m using the default nouveau drivers for my nvidia

    Use Nvidia’s proprietary drivers, they’re much better.

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • @Wyn Thank you for your recommendation … but I think it does not solve the problem
    I have two weeks with this new installation and never had delays nouveau, this started a few hours ago

  • Please post your logs. See the sticky post out in the top level of this category for instructions.

    Cheers!

  • @lots.0.logs Hi… annex logs records -->> Logs.tar

  • Did you install any new firefox extensions recently? If you did, try removing them ;-)

  • Definitely not… always use the same extensions from the original installation antergos, the delay is even without starting firefox.
    I installed the nvidia drivers and continue the delay.

  • @lots.0.logs I uninstalled the nvidia driver, and reinstall nouveau again… but the delay is still there.
    I definitely believe that it is a problem of gnome shell with a change of library in any prior installation or upgrade.
    The big question is… what and where?

  • @internauta2000 There’s nothing in your logs to indicate that. Your logs are, however, filled with messages from one of your firefox extensions. It can’t hurt to try disabling your extensions just to see the result :wink:

  • @lots.0.logs Thanks for giving your time to my… I understand it says about firefox and assure you that I try everything. Some research here and there I met some post that mention the inconvenience of gksu and remembered that I install to run scripts as root from nautilus. I’m really not too sure about this, but I think this has altered user privileges across multiple files and folders in the system causing a malfunction of gnome and I fear also the kernel because I use gksu instead of gksudo… but I repeat this is nothing more than a baseless theory from me.

  • If the issue is permissions related then it can be easily corrected with the following command:

    sudo chown -R orlando:users /home/orlando
    
  • @lots.0.logs This command can run on user configuration files… but as I correct privileges changes in files and folders in the system directory possibly made by gksu?

  • The owner of system files doesn’t affect anything. There are a few exceptions to that but overall it shouldn’t matter. You can try these commands, though I am skeptical that they would resolve your issue. That being said they can’t make it worse so…

    su
    find / -type f -exec chmod 644 {} \;
    find / -type d -exec chmod 755 {} \;
    

    Ultimately there is no way for me to know what actions you may have done, whether they be intentional or unintentional, to cause the issue you are experiencing. My advice is to save your personal files and then reinstall Antergos.

    Cheers!

  • @lots.0.logs The foregoing definitely not a good idea… to reboot after the grub appears this:

    ERROR: Root device mounted succesfully, but /sbin/init does not exist.
    Bailing out, you are on your own. Good luck.

    sh: can’t access tty; job control turned off
    [rootfs /]# _

    Any idea that doing now?

gnome242 update46 Posts 15Views 3093
Log in to reply