• Can't enable touchpad!


    My touchpad on my Asus G46VW laptop isn’t working. I was using my mouse at the moment so I went into the settings and disabled it, but after I did, it didn’t appear there anymore. It only works on the lockscreen now and not the actual OS. please help!

  • Hi,

    Try installing this package from the AUR and then reboot:

    yaourt -S elantech-asustouchpad-dkms
    
  • it didn’t work. I have also tried installing elantech’s psmouse driver. that didn’t work either.

  • @lots.0.logs is there anything else I can do? The command you posted didn’t do anything. I still have the same issue. I should probably point out that the touchpad works on the lockscreen, but as soon as I login, there’s no trace of it. When I do Xinput, I see that is input number 15. It is still detected, but it just doesn’t work on the desktop.

  • Which desktop are you using? Did you try to configure the touchpad within the system settings?

  • @lots.0.logs Gnome. the touchpad used to appear in the system settings until I disabled it because it was annoying me while I was typing so I disabled it in the gnome system settings.

    After that, when I tried to reenable it, it didn’t appear under the mouse settings, and now I can’t use my touchpad unless i’m at the lockscreen.

  • @lots.0.logs I just reinstalled Antergos. I am not touching those mouse settings, but I can still disable and reenable the touchpad from the terminal, which is what i’ll be doing from now on. Thanks for your help anyway.

touchpad30 drivers30 mouse41 Posts 7Views 1726
Log in to reply