• [Solved] after kernel 4 upgrade: failed to get gcc information


    Dear all,

    after the recent kernel upgrade to version 4 I have problems compiling kernel module, most notably the vmware modules:

    sudo /usr/bin/vmware-modconfig --console --install-all
    Failed to get gcc information.
    gcc --version
    gcc (GCC) 4.9.2 20150304 (prerelease)

    Somebody reported an issue in the kernel upgrade announcement thread as well.

    Since the upgrade I have issues with afs as well, which might be related. Somebody also reported this issue in the vmware community with gcc 5.1, so far no reply.

    Does anyone have a solution or idea? Neither DuckDuckGo nor Google were of help. :(

    Thanks and cheers!

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • Hi,

    I would recommend waiting until the new GCC is moved out of testing repo. Though if you don’t want to wait, you can find the details here:

    https://bbs.archlinux.org/viewtopic.php?id=196778

    Cheers!

  • Thanks! I’ll be patient then !

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • I like that we bring these matters to be discussed. I think it’s good.

  • Sorry, forgot to update this thread. The issue was solved some time ago with one of the regular updates.

    Cheers!

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

kernel71 gcc2 kernel module2 vmware13 Posts 5Views 3026
Log in to reply