• [Solved] No wifi once installed


    Hello,

    I installed AntergOS for the second time on a second computer and I have the same issue. The wifi works fine when I use the liveCD, but once it is installed I don’t get to connect anymore. I can’t even choose or see the differents networks. I installed it with cinnamon. The wireless chip is Broadcom 4313.

    Thanks in advance,

  • Check if you have these installed

    iw,
    wireless_tools
    wpa_supplicant
    wpa_actiond

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • Every packages are installed.

  • Does your wifi turn on? Maybe a light indicates if its on or not.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • if it doesn’t turn on, copy-paste this in terminal and hit enter

    systemctl start NetworkManager.service

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • Yes my wifi is turned on, a led is turned on.
    I tried the command but it does nothing…

  • Networkmanager.service does the work in background.

    I don’t use cinnamon so can’t help any further.
    If you’re still unable to connect to your wifi, then lets wait for the devs.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • No it doesn’t work… I will wait to see for more answers.

  • Hi,

    Install rfkill if you don’t have it installed and run:
    sudo rfkill list

    Oh, give also the result of running these commands, please.

    • sudo iw dev
    • dmesg
    • sudo lspci -nnn
    • sudo lsusb -nnn
  • Here is the result of every command above :
    https://gist.github.com/Fanaen/9c397f7226024e06acad
    The dmesg is a bit large…

  • @m4tthieu526 Damn Broadcom…

    Do you have broadcom-wl installed?

    EDIT: You have more info here: https://wiki.archlinux.org/index.php/Broadcom_wireless

  • Yes, the package broadcom-wl is installed. I have also checked other drivers’ packages (seeking for conflicts): b43-fwcutter is the only one installed.

    Without any brcm80211 package, the fix “Device with broadcom-wl driver not working/showing” doesn’t apply to this case.

  • Hello,

    My issue was resolved with the last update of broadcom-wl.

    ++

Posts 13Views 2871
Log in to reply