• Trying to add HP printer after fresh installation


    Hi,

    On a relatively fresh installation I’m now trying to add my HP Officejet G85 printer. I went to the configuration panel and selected Printers. Then hit Unlock and “Add new printer”. The printer, connected via USB, is being detected so I hit Add. The dialog now shows the printer listed with a sub-title “Busy installing” (or equivalent, I’m on a Dutch translation).

    So far so good, I thought… but it remains in that “Busy installing” status indefinitely. Going back to the control panel, then into Printers again the printer is not listed. Tried the same procedure again with same result.

    Any tips on how to proceed or debug are highly appreciated :)

  • There has been a lot of problems with CUPS in the past few months. Please, search in this forum for other threads as maybe there’s a solution for you there.

    More than that, I really do not know how to help.

    Cheers!

  • @karasu thanks for the repsonse :) I did not find anything on these forums but did find https://wiki.archlinux.org/index.php/CUPS#HP_Printer where it is suggested that I can also use hplip (installed) with hp-setup to do the proces. Sadly sudo hp-setup -u results in an error:

    error: HPLIP is not installed properly or is installed without graphical support. Please reinstall HPLIP
    warning: Qt/PyQt 4 initialization failed.
    error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode.

    while sudo hp-setup -i seems to not be able to find any PPD file so it exits with an error too:

    error: PPD file required. Setup cannot continue. Exiting.

    I know similar issues where present in older Ubuntu versions but in the most recent one these are resolved…

  • @RavanH Try installing python-qt4 and python2-qt4 (I do not know if hp-setup is python2 or python3)

  • OK, short update as I seem to have reached a (sort of) solution that might benefit others…

    1. Open nautilus and browse to /usr/share/ppd/HP

    2. Find an approriate PPD zip package, in my case I took hp-officejet_g85.ppd.gz, and double-click to open the zip

    3. Extract the PPD to your home directory (by lack of a better location, please advise!)

    4. Connect printer via USB and turn it on

    5. Open a terminal window and enter

    sudo hp-setup -i

    to start the HP Setup Utility

    1. You’ll be asked

    Enter number 0…2 for connection type (q=quit, enter=usb*) ?

    Hit enter

    1. Response will be depending your printer:

    Using connection type: usb

    Setting up device: hp:/usb/…?serial=…

    Now wait a (in my case) long time for

    Please enter a name for this print queue (m=use model name:’…’*, q=quit) ?

    and enter the suggested name or any other you like and hit Enter again.

    1. Now comes the error:

    error: No PPD found for model … using old algorithm.
    error: Unable to find an appropriate PPD file.

    Would you like to specify the path to the correct PPD file to use (y=yes, n=no*, q=quit) ?

    Type y to confirm and hit Enter.

    1. Now type the full path and filename of the previously extracted PPD file after

    Please enter the full filesystem path to the PPD file to use (q=quit) :

    So in my case it looked like /home/myusername/hp-officejet_g85.ppd

    1. Answer all remaining questions with a simple Enter and wait (again it might take a while) for the process to terminate.

    By now you should have your HP printer listed under Configuration > Printers and a correctly printed test page in the printer tray :)

  • Quick update: I installed the testing release recently and found that the ‘normal’ graphical Printers interface now allows me to detect and install the HP printer. Still, it falls back to the generic text printer driver by default so you’ll have to click that entry and choose to find (long list!) and select the correct printer driver manually.

  • Thank you so much, thanks to your post I have been able to install via USB (HP_3050_j610_series), because for me wifi was impossible.

    Autodidacta en la VIDA …y en Linux, también.

  • :+1: I don’t think I have ever been on a forum with more relevant and up to date information when I need it. Thank you very much, now my printer is working great.
    Typed too soon and then realized that my scanner is still not working. Any suggestions? It’s an HP Deskjet 1510 and this is the first time I’ve had problems with a linux distro recognizing the scanner part.
    Also the first time using Antergos.

  • @pasanov

    Could you open a new thread with your problem? It’s just this way the forum is better organised (and more users will see your question, too).

    Thanks!

  • @RavanH Hi,
    have you tried to install specific HP driver already ? Here is a link which might help you : http://h10025.www1.hp.com/ewfrf/wc/softwareCategory?os=2020&lc=en&cc=us&dlc=en&sw_lang=&product=60399#N191

    Good luck!

printer25 hplip4 hewlett packard1 driver36 cups11 Posts 10Views 4508
Log in to reply