• [SOLVED] Cheese wants cluttervideosink


    Just moved from Openbox to Gnome 3.16.
    Installed cheese.

    When I open cheese, I get greeted by “One or more needed Gstreamer elements are missing : cluttervideosink”

    What do I do?

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • Hi,

    How did you install cheese?

    It should have installed clutter-gst2 with it. Have you got this package installed?

    Cheers!

  • I installed it via pacman

    pacman -S cheese

    Edit: Actually, didnt have to do that, it came with the group ‘gnome’

    yes, clutter-gst2 is installed.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • I’ve found this in another forum, check if this helps:

    rm ~/.cache/gstreamer-1.0/registry.x86_64.bin

    Cheers!

    EDIT: If it still does not work, try this:

    1. Remove clutter-gst package
    2. Remove ~/.cache/gstreamer-1.0/
  • Thanks karasu,

    Removing clutter-gst, totem and rm’ing ~/.cache/gstreamer-1.0/ worked!

    This is surprising because I did the same yesterday after checking out archforums, removing them didnt make any difference then. You’re a magician, karasu 😄

    Now, I’m half happy. Cuz It got rid of the error, but now shows a black screen only.
    It shows black screen on Ubuntu as well, so maybe its my webcam’s problem, maybe.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • I’ve had similar problems for several years on and off with Cheese showing black screen and also crashing sometimes as well. Recently solved it by:

    Use Hardinfo to get details of webcam connection from Devices/Input devices e.g. usb-0000:00:14.0-9/button
    Go to Dconf editor Org/gnome/cheese
    Insert webcam connection details in ‘video-path’

    Hardinfo can be installed from Community repository. Please note it shows up as ‘System Profiler and Benchmark’ in Gnome Shell

  • Changed the camera resolution from 640x480 to 320x240 and now I can see myself! 🙂

    Problem solved, for now! If I face it again in future, I’ll try what @Xler8 said.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

Posts 7Views 4437
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.