• Broadcom BCM4313 interface not showing. Fresh antergos install.

    On the live cd I used to install antergos, wireless worked out of box. After booting into the new install, I find that there is no option on my gnome DE to connect to wireless. My assumption is it should have worked at this stage.
    After looking through several wiki articles and a few forum posts, I thought these command outputs might be useful for troubleshoot this. Please have a look at the outputs for ‘ip link’, ‘ip a’, ‘lspci -v’, ‘lsub’ here :
    The wireless interface is not showing up on ‘ip a’. However lspci -v shows the correct device with ‘Kernel modules: bcma’
    After installation via livecd, somehow grub was not properly installed(apparently a known issue), so I had to boot into livecd again, chroot into my new install and install grub properly. At this time, I modified /etc/resolv.conf and executed
    ip addr add broadcast dev eno1
    Could those operations have caused this?

    What more information should I provide here? What troubleshooting steps should I take? Am I wrong in assuming that wireless should have started working after installing gnome-de from antergos install? Especially since it worked in the livecd?

    After reading through several posts, I suspect it might be relevant to add that I am dual booting with windows 8. Also, there is a hardware button (actually a fn+f12 combination) to turn wifi on-off. On gnome, pressing (fn+f12) toggles the airplane mode, but does not turn state of wifi light.

    Installed rfkill . rfkill list Output : http://hastebin.com/otatijepat.sm

    Output of dmesg | grep bcma : http://hastebin.com/opafuzimaj.py

    Apologies for poor code formatting, I’ll learn the correct syntax soon.

  • This post is deleted!
  • This post is deleted!
  • This post is deleted!
  • @Jinal-Kothari Hi, have you tried the broadcom-wl driver? (I think you should blacklist bcma, but I’m not sure).

  • @karasu , thanks for the suggestion. I ended up installing Arch with similar set of component as Antergos. The wifi interface works as expected.

  • An update to bcma breaks BCM4313 wireless cards at this time.
    Currently it will be required to pull in the broadcom-wl-dkms and linux-headers to bring the wireless card back online.
    $ sudo pacman -Sy linux-headers
    $ yaourt -Sy broadcom-wl-dkms
    Instruction will show up once installed.
    Make sure you blacklist what it requests and modprob wl
    Once complete reboot just for sanity.

gnome358 wireless37 broadcom22 Posts 7Views 3295
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.