• Unable to Install a new package


    I am not able to install a new package, I got error like this.

    error: GPGME error: No data
    error: database ‘core’ is not valid (invalid or corrupted database (PGP signature))

    Also if I used #pacman -Sy, I got the following error:

    error: GPGME error: No data
    :: Synchronizing package databases…
    error: failed to update core (unable to lock database)
    error: failed to update extra (unable to lock database)
    error: failed to update community (unable to lock database)
    error: failed to update antergos (unable to lock database)
    error: failed to synchronize any databases
    error: failed to init transaction (unable to lock database)
    error: could not lock database: File exists
    if you’re sure a package manager is not already
    running, you can remove /var/lib/pacman/db.lck

    Please anyone know how to fix it!

  • @parveen-kumar said:

    /var/lib/pacman/db.lck

    Try this:

    sudo rm /var/lib/pacman/db.lck
    sudo pacman -Syyu
    

    Cheers!

  • @lots-0-logs Thanks! Now it’s working

pacman80 Posts 3Views 2364
Log in to reply