• Openbox Installation failed


    Hi,
    I tried to install x64 bit installation and it failed after I chosen Openbox desktop during installation.

    I do not exactly remember error message but it said something like refreshing package list and some error. I had chosen CLI installation.

    Thanks.

  • Hi,
    I tried to install x64 bit installation and it failed after I chosen Openbox desktop during installation.

    I do not exactly remember error message but it said something like refreshing package list and some error. I had chosen CLI installation.

    Thanks.

  • I couldn’t find any errors installing Openbox through the CLI Installer, maybe it was a network failure. Could you try again?

  • I will have to update mirrorlist because it is taking too much time, and many times it gives me timeout error and probably it then tries different mirror. What is a root password for installation. I saw there are two mirror lists, one is antergos mirrorlist and another is arch mirror list. Should I change mirrors in both the list?

  • antergos-mirrorlist is for our own repo, mirrorlist is for the repos provided by Arch Linux. But you shouldn’t need to modify nothing because the CLI Installers does paralell downloads, so it is better to have every server uncommented. The errors you see are normal though. It’s trying to download from one location but maybe that server holds an old version or simply times out, the installer will try with another mirror while still downloading other packages from other mirrors.

    The live environment doesn’t have any password, just execute sudo with the command you want and if you are having problems with this, like changing the system’s clock in gnome just type; [b:qt1hruma]sudo passwd antergos[/b:qt1hruma] and select a password of your choice

  • I tried twice today. Both the time after selecting Openbox as desktop, it says Refreshing Package list and says Installation failed. I tried twice.

    Anyway because I formated my swap partition which I use for Manjaro also, my uuid of swap partition is changed. Now I am facing one error while booting. It says

    running eraly hook[udev]  
    ..  
    ..  
    running hook[resume]  
    Waiting for 10 seconds for device /dev/disk/by-uuid/ some uid number.
    

    [http://forum.manjaro.org/index.php?topic=6588.0][0]">[http://forum.manjaro.org/index.php?topic=6588.0][1]

    This is nothing to do specific to Manjaro or Antergos, but it is something to do with Arch Linux. Once I fix this problem , I will try Antergos again.

    Thank you.

    [0]: <a href=
    [1]: http://forum.manjaro.org/index.php?topic=6588.0

  • Booting what? Antergos installed? or the LiveCD?

  • Antergos never got installed because as I said I tried twice, it gave me error saying Refreshing Package list and then Installation Failed.

    Booting my old Manjaro in another partition. The swap partition I share between two linux instllation. I already I have Manjaro in another partition. I was trying to install Antergos in another partition. I was planning to share swap partition between two. I formatted swap partition while trying to install Antergos. Now uuid of swap partition is changed. Now my Manjaro gives me error while booting.

  • I tried again, it gives me same error “Refreshing Package Database” then “Installation Failed”

  • I have managed to install using Graphic Installer this time.

    In Graphical installer, it did not allow me to install without formatting root partition. I had to format root partition. In the past I have installed other distro without formating root partition. But thats ok. Finally I have installed it.

  • Though I succefully installed, but I just have one question though. Is it possible to install without formatting root partition. The graphical installer does not allow it I guess. I do not have big harddisk. I do save some files on the root partition. I do not want to format root partition during install. What I do is, I delete all other folders except my files on root partition. Then I install. But last night I had to move my files from root partition to some other place and allow graphical installer to format root partition.

    Is there way to install without formating root partition if I have to install it again on another partition?

  • The files that you save like this should be in a separate partition called /home. That way home (and storage, see below) can be shared between the different distros you have setup.

    When setting up a new hard drive I usually make partitions as such:
    > swap (about 2 to 4GB is plenty) (swap should be first as that is the closest to the center of the spinning disk, so this makes access the fastest)
    > root (about 7 to 17GB)
    > *(you can partition a second root here if necessary. But I would suggest you use virtualbox instead to test additional distros)
    > home (about 4 to 7GB)
    > storage (The rest of the disk for your data storage. This I mount to my /home/username directory for easy access.)

    BTW, it is usually the best to always format root on any install. Only under a strange and rare situation would you not want to.

    Hope this all makes sense. All the best in getting your system running smoothly.

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

  • I have seperate /home, /boot, and / partitions for two distros. swap 4GB I share in the two distros. Size of my /home partitions is nearly equal to / partitions in both the distros. Sometimes I run out of space on /home partition because my harddisk is only 250GB out of which around 175GB I use in Windows, though I am planning to buy external harddisk soon. But I was curious to know if there is way to install Antergos without formating root partition, because I have done this for other distros.

    In my first distro I have
    /boot 150 MB
    / around 25 GB
    /home 21 GB

    swap 4GB shared between two dstros

    distro2

    /boot 100 MB
    / 15 GB
    /home 10 GB

    rest is Windows.

    If I share /home partition between two distros, then I will have to use seperate user name for both the distros – correct me if I am wrong.

  • The graphical installer doesn’t allow you to install without formating root. You can with the CLI Installer, it is the only way.

    Sharing a home partition… I don’t think you must use different user names… as long as the user has the same uid I can’t see the problem, but maybe I’m wrong :S

  • I read somewhere that using same user name for two distros in same home partition is not straight forward, though I may be wrong because I never tried it. Yeah it may something to do with uid. But I never tried it.

    About CLI installer, in my 3 attempts, the installation failed when it said refreshing package list, this is why I tried graphaical installer and it worked on first attempt but I had to format / partition.

    Anyway thanks for the help, I will mark this thread as SOLVED. I think I will have to buy external harddisk sooner.

  • As I mentioned, you really only need one ‘working’ distro, and the sizes for the partitions that I mentioned are plenty. You don’t need a separate boot partition anymore.

    As for the other distro, and of course, even *Windows*, I highly suggest *virtualbox*. This way you can free up a ton of HD space for /home/username/storage, and you can operate virtualbox out of storage. Which means you probably will not need to buy another hard drive.

    Yes, the /home directory is shareable as @faidoc said above. But again, why go to that hassle when you you’ve got so much flexibility with virtualbox.

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

  • No, it’s not windows or any other distro which taking up lot of space. The space is used by files I have. I have used virtualbox in the past.

  • Reopening this thread again. Today I downloaded fresh iso to install. I used CLI installer. I got same errors which I got last time( Sep 03, 2013 ) when I installed last time. I chose openbox. It says "Installation failed " Then I press enter on OK. Then it says “Refreshing Package Database” The it says "Installing Packages please wait … " And again says “Installation failed”

  • Hi, please add this to our issue tracker on github: [http://github.com/Antergos/Cnchi/issues][0]">[http://github.com/Antergos/Cnchi/issues][1]

    Thanks!

    [0]: <a href=
    [1]: http://github.com/Antergos/Cnchi/issues

  • Finally installed using Graphic Installer. The installer is very nice. Only thing it did not allow me to install without formatting / (root) partition. I had to format root partition. But that’s ok.

    Installation took long long time. Installation broken twice due to power failure, my internet got disconnected while it was downloading packages. It happened twice. Once when it was downloading Antergos Wallapers, and second time while downloading google fonts. It was too frustrating because my internet is not very fast. I had to start all over again. Both time I was waiting for more than 2 hours. But it was worth waiting. I am so much impressed! You guys have done really really nice distro. It looks so nice. Wow ! I think it’s best Arch based distro I have seen so far. Congratulations to all of you!

    I wanted ask. I have selected printing services during installation. Now I feel unnecessarily I selected it because those packages will be updated all the time when I update my system and I do not use printer on this system. So it is quite unnecessary. I want to remove packages for printing service. Please tell me name of the packages for printing services so that I can remove it.

    Again Congratulations to all for such nice look and feel.

Posts 22Views 3074
Log in to reply