• [Solved] Flickering login screen after update


    I’ve just updated my Antergos system and, reboot, I find that the login screen is now very flickery. I’m using Gnome and have just upgraded to version 4.0 of the kernel.

    Does anyone know how I can fix the flicker?

  • @expatpaul After some experimenting, I’m pretty certain that this is something to do with Wayland. So the issue is that Wayland is causing a flicker on the screen.

    The next question, therefore, is does anyone know how to switch off Wayland for the Gnome login screen?

    Or, how do I go about installing an alternative login screen?

  • @expatpaul Wayland is still experimental, I do not recommend using it yet.

    Well, if you want, you can install GDM:

    sudo systemctl stop lightdm
    sudo systemctl disable lightdm
    sudo pacman  -S gdm
    sudo systemctl enable gdm
    sudo systemctl start gdm
    

    Cheers!

  • I’m not in any great rush to use Wayland. As I understand it, this has become the default with Gnome 3.16. While I can avoid Wayland in Gnome itself, the login manager is using it and I don’t see any way od switching it off.

    I have just checked and I already have GDM installed and not LightDM. If I try to install and LightDM, is there anything I need to be aware or wary of?

    Thanks 🙂

  • I have installed and started LightDM and the flicker is gone 🙂

    The one thing to note is that I also needed to manually install the lightdm-gtk-greeter but, apart from that, everything is lovely again.

    Many thanks

gnome304 Posts 5Views 2557
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.