• [Solved] KDE update issue


    I’m on Gnome but testing KDE in virtualbox. For a few weeks everything went on smoothly but now everytime I try to update I get “Errors occurred, no packages were upgraded.” after pacman downloads everything.
    kde.jpg

    I tried to clean the cache, but I always get the same error. Any idea?

    Intel NUC D54250WYK, 16 Gb RAM, 1 Tb SSD
    Multi -boot (no MS-Win &no UEFI) Legacy MBR with GPT

  • Hi,

    You have a conflict when trying to update the webkit2gtk package. Have you installed jsc manually?

  • ??? uhu?? no I didn’t install jsc manually
    Thanks for the prompt reply.
    Can it be that it’s been too long without updating? Being a VM I didn’t use it every day.

    Intel NUC D54250WYK, 16 Gb RAM, 1 Tb SSD
    Multi -boot (no MS-Win &no UEFI) Legacy MBR with GPT

  • Ok problem solved. I did a quick search and found
    https://wiki.archlinux.org/index.php/Pacman#.22Failed_to_commit_transaction_.28conflicting_files.29.22_error
    (yes for now we must admit that arch wiki is better than useless antergos wiki ;)
    sudo pacman -S --force webkit2gtk
    sudo pacman -Syu
    …and everything was up & running again! peace & love ANTERGOS is still my distro of choice

    Intel NUC D54250WYK, 16 Gb RAM, 1 Tb SSD
    Multi -boot (no MS-Win &no UEFI) Legacy MBR with GPT

  • Hi,

    Yeah, I knew that with --force you could install over it, but you did not resolve the problem. You have now two packages that installed the same files and you don’t know why… :P

    From the wiki:

    The problem is usually trivial to solve. A safe way is to first check if another package owns the file

    Did you do that? Well, I don’t think you’ll have any problems, but who knows…

    Cheers!

  • @karasu Yes I did a check with pacman -Qo /xxxxxx but if I remember well I got something like ‘no such file or directory’… may be I mistyped the file path, anyway I don’t quite understand what it all means (having 2 packages that installed same files???). I will let you know if I get in troubles because of this.
    For now I’m ok, after all I’m just testing a VM. But I would like to install for real Antergos KDE later on.
    And by the way my Antergos Gnome shell 3.16 is working perfectly since the main update.
    Thank you guys for your support.

    Intel NUC D54250WYK, 16 Gb RAM, 1 Tb SSD
    Multi -boot (no MS-Win &no UEFI) Legacy MBR with GPT

Posts 6Views 1161
Log in to reply