• i8K - unable to get SMM Dell signature


    Hi,

    Please help - I’ve recently started using Antergos (the KDE version). All was running smoothly until one day the package manager wouldn’t update the package lists due to a database lock. I read that deleting the temporary lock file might solve the problem. I did this but the next time I started up the laptop, I received the following message on the bootup screen:

    i8K - unable to get SMM Dell signature.

    The boot screen freezes after this message and nothing further happens.

    I’ve tried booting into the fallback version of Antergos but this returns the same error. I don’t think it’s a hardware fault because the laptop still boots into Windows Vista installed on another partition. I would have just done a clean install on the partition except for the fact that I rather carelessly moved a whole bunch of photos from my phone onto the Antergos partition (my user files and boot partition are one and the same unfortunately).

    If nobody is able to help with the bootup problem, please could someone at least suggest how to retrieve my photos. I’ve tried to boot from an ubuntu live cd just so that I could mount the partition with the photos on it but the file manager wouldn’t let me access the user files on the Antergos partition due to a permission error. The partition doesn’t even seem to show up in Windows Vista.

    My hardware is an ancient Dell Vostro 1000 laptop.

    Any help would be much appreciated.

    Thank-you!

  • @Organic-Sage said:

    i8K - unable to get SMM Dell signature.

    That appears to be a regression in the latest kernel version. Try installing the LTS kernel and then choose it from the Grub menu at boot:

    1. Press e when grub appears.
    2. Find the kernel boot command and add the following to the end of line: systemd.unit=multi-user.target
    3. You should fingers crossed be looking at the terminal login prompt. Log in and install the LTS kernel: sudo pacman -S linux-lts
    4. Now update your grub config: sudo grub-mkconfig -o /boot/grub/grub.cfg

    Let me know how it goes. Cheers!

  • @lots.0.logs Hi! Thanks so much for your help - I managed to boot into the command line and rescue my photos! Followed the rest of your instructions but unfortunately it hasn’t seemed to solve the problem. Now it hangs at the step before the i8k error message. No worries though - I’m just going to do a clean install on the partition.

    Thanks again for helping to save my precious memories :)

    Ta
    G

  • You’re welcome :smile:

Posts 4Views 2007
Log in to reply