• [Solucionado] Error actualizando Antergos.


    Hola,

    Esta es la primera actualización del sistema después de su reinstalación, me da un error, no puede sincronizar la base de datos:

    [[email protected] ~]$ sudo pacman -Syyu
    [sudo] password for keos:
    :: Sincronizando las bases de datos de los paquetes…
    error: no se pudo actualizar core (no se pudo bloquear la base de datos)
    error: no se pudo actualizar extra (no se pudo bloquear la base de datos)
    error: no se pudo actualizar community (no se pudo bloquear la base de datos)
    error: no se pudo actualizar antergos (no se pudo bloquear la base de datos)
    error: no se pudo sincronizar ninguna base de datos
    error: no se pudo iniciar la operación (no se pudo bloquear la base de datos)
    error: no se pudo bloquear la base de datos: El fichero ya existe
    si está seguro de que no se está ejecutando un
    administrador de paquetes, puede eliminar /var/lib/pacman/db.lck.

    Cuando navego hasta db.lck este está como inutilizado, con una cruz roja, nada que hacer …

    Un saludo.

    Graphics: AMD Radeon HD 7640G integrated graphics
    GPU: AMD/ATI Trinity [Radeon HD 7640G]

    Xfce

    Sistemas Operativos:
    Manjaro y Antergos

  • Olvido decir que reinicio y trato con yaourt, pero:

    [[email protected] ~]$ yaourt -Syyu
    ==> Pacman está en uso, espere por favor.

    Graphics: AMD Radeon HD 7640G integrated graphics
    GPU: AMD/ATI Trinity [Radeon HD 7640G]

    Xfce

    Sistemas Operativos:
    Manjaro y Antergos

  • Hola @Keos

    Asegúrate que no estás utilizando ni pacman, ni pamac, ni pacmanxg, ni yaourt (es decir, ningún programa de actualizaciones) y abre una terminal y escribe:

    sudo rm /var/lib/pacman/db.lck

    Saludos!

  • Hola karasu, actualizo el sistema, solo que al final aparece algo que no comprendo, no se si eso fue lo que ocaciono el problema:

    ==> The polkit-gnome agent is no longer autostarted by default
    except in GNOME Flashback.
    For Xfce, LXDE etc., lxsession is the suggested lightweight alternative.
    See https://wiki.archlinux.org/index.php/Polkit#Authentication_agents
    for more details.

    Voy a esa direccion, tengo Xfce, por lo que me lleva despues a esta otra:
    https://aur.archlinux.org/packages/xfce-polkit-git/ pero una vez ahi, me pierdo, no se que es lo que se esta sugiriendo ni como …

    Gracias y un saludo

    Graphics: AMD Radeon HD 7640G integrated graphics
    GPU: AMD/ATI Trinity [Radeon HD 7640G]

    Xfce

    Sistemas Operativos:
    Manjaro y Antergos

  • Hola,

    No te preocupes, puedes ignorar el mensaje.

    Saludos!

  • En mi Antergos XFCE siempre me sale el mensaje cuando voy a actualizar por terminal

    administrador de paquetes, puede eliminar /var/lib/pacman/db.lck

    Por lo que siempre tengo que proceder desde la terminal

    sudo rm /var/lib/pacman/db.lck
    

    Al final he desinstalado Pamac, yo no nunca lo uso, me gusta más Octopi, que es el que siempre uso, y asunto arreglado.

    Ya no me ha vuelto a salir el mensaje de bloqueo de /var/lib/pacman/db.lck al actualizar por terminal.

    Antergos (Gnome)

  • @karasu Gracias amigo me sirvio tu solucion, estoy feliz en tener en mi pc Antergos creo que es lo mejor que he tenido la verdad me gusta mucho antergos, y felicito a los desarrolladores de esya magnifica distro linux.

  • Encantado de que te guste la distro. El problema del ficherito es que pamac bloquea la base de datos y luego no suelta el fichero.

    Los desarrolladores estan informados del problema, pero no parecen estar por la labor de solucionarlo. Veremos.

    Saludos!

  • @karasu said:

    Hola @Keos

    Asegúrate que no estás utilizando ni pacman, ni pamac, ni pacmanxg, ni yaourt (es decir, ningún programa de actualizaciones) y abre una terminal y escribe:

    sudo rm /var/lib/pacman/db.lck

    Saludos!

    Una vez mas Karasu salvas mi pc jajajaj, me paso lo mismo que Keos, y con esto arreglamos el problema.

    Saludos a todos desde Chile!

    Antergos Gnome - Lenovo G4070
    Antergos XFCE - Asus E-11
    Xubuntu 16.04.4 LTS - Dell D630
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc

Posts 9Views 13398
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.