• Nvidia multimonitor setup [SOLVED]


    I’ve been trying for hours to get both monitors working and can’t figure it out. With the default drivers that antergos ships with both work perfectly, but after switching to the nvidia drivers, My main UHD Monitor works great, but the secondary just goes into sleep mode (GRUB is displayed on the secondary monitor during boot, but as soon as it gets to gdm it switches to my main and puts the second to sleep.)
    sli is also setup. When I go into gnome settings it does SHOW the second monitor, but says its “off” after changing it to on, saving, restarting, it shows it as off again.

    Here is my /etc/X11/xorg.conf file:
    xorgconf.tar

    Any help would be greatly appreciated!! :D

  • Did you install the nvidia-utils package and use the nvidia-settings gui app to configure it?

  • @lots.0.logs said:

    Did you install the nvidia-utils package and use the nvidia-settings gui app to configure it?

    Yes, but after configuring the second display, saving it, and rebooting, it reverts back to being off.

  • You have to save it to your X config file. There is a button in the gui to do that.

  • @lots.0.logs said:

    You have to save it to your X config file. There is a button in the gui to do that.

    Yeah, I did that… it saves as /etc/X11/xorg.conf which is what I attached in the first post.
    and here is also my 10-monitor.conf
    10-mon.tar

  • Did you also save the settings for the settings app? There should be a file in your home directory named .nvidia-settings-rc. I’m not sure if that’s relevant to the issue. Mine worked after saving the xorg conf file. I didnt have to do anything else. Are you using GNOME or Cinnamon? If so, be sure to use their display setup modules (in their system settings) to configure your displays how you want them. What might be happening is that they are using the display arrangement that was saved when you first booted.

  • @lots.0.logs I’m using gnome, and the same thing happens when I change the settings via Settings > Displays > I see the second one and it says “off” but when I set it to secondary display, then reboot, it just reverts back to off. And my .nvidia-settings-rc doesn’t appear to have anything to do with monitors

  • Delete the following file then use the GNOME display settings module (again) to configure the arrangement.

    ~/.config/monitors.xml
    
  • @lots.0.logs Now I can’t see the second monitor in the gnome settings, But I can still see it in nvidia-settings but it says “Configuration - Disabled” and when I change it the only option I have is “X Screen 0” but saving it like that reverts back to disabled.

    Haha! I reverted back to a xorg.conf file and 10-monitor.conf file from a few hours ago since I was messing around with it so much, and now that I deleted that file, it works!

    Thank you sir @lots-0-logs ! ;) Didn’t know I would have a conflicting file.

  • You’re welcome :smile:

Posts 10Views 2261
Log in to reply