• After antergos installation, I boot in to the system but it goes blank


    After antergos installation, I boot in to the system but it goes blank while grub is loading properly. I tried lot but still i am not able to load GUI of antergos gnome version. I am new to arch linux , plese help me, I am stuck from last two days.
    When it goes blank, ALT-CTL+F2 give me terminal access and then I typed #startx that result “connection to xserver is lost”.
    I have GPT partition table on Intel mother board.Model-Acer aspire 5920
    Please help!

  • I had the same issue and ended up installing GDM as suggested by @ant77 in a previous thread.

    sudo systemctl disable lightdm
    sudo pacman -S gdm
    sudo systemctl enable gdm

  • Thanks @bazini2880 , for your kind reply.
    This issue is solved now but another issue might need your attention. I made it to bypass the blank screen not your way, I only did to check " login automatically " and uncheck “login required your password” during installation. When installation is finished I directly goes to Gnome desktop without asking my credential.

    But I think this issue is still there, when I lock the screen it goes white blank. I am able to login again. So may be this issue is due to Lightdm. Those command you recommend may help full.

    So I will let you know what going to next.

  • sorry for late reply @bazini2880 , now issue had been resolved. Thanks!!

  • @parveen-kumar

    It looks like a lightdm problem.
    Try this, instead of running startx, run these commands:

    sudo pacman -Syu
    sudo pacman -S lightdm lightdm-gtk-greeter
    sudo pacman -S lightdm-webkit2-greeter
    sudo pacman -S lightdm-webkit-theme-antergos
    sudo systemctl restart lightdm
    

    Tell us how it goes

    EDIT: Sorry, I didn’t see you already solved it. Damn it… xD

  • LOL!! It’s working perfactly:satisfied:

  • I can’t start my antergos xfce after a new instalation, the screen stays white.
    I’ve tried installing gtk-greeter, webkit2, and the theme, but it doesn’t work.
    Please help me.
    the logs: Logs.tar

  • Hi @jhoeD
    Are you sure you updated your system first? sudo pacman -Syu
    And then:

    sudo pacman -S lightdm lightdm-gtk-greeter
    sudo pacman -S lightdm-webkit2-greeter
    sudo pacman -S lightdm-webkit-theme-antergos
    sudo systemctl restart lightdm
    

    ???

  • Hi.
    Yes, I’ve updated the system first.

  • @jhoeD : As a quick fix, try to use gdm.

    sudo pacman -Syu
    sudo pacman -S gdm
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    sudo systemctl stop lightdm
    sudo systemctl start gdm
    

    Cheers!

  • @karasu said:

    @jhoeD : As a quick fix, try to use gdm.

    sudo pacman -Syu
    sudo pacman -S gdm
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    sudo systemctl stop lightdm
    sudo systemctl start gdm
    

    Cheers!

    Its done, but install the gnome shell. Nice, but weight for my compaq mini

  • Hi @karasu
    Installing gdm with all the gnome shell is very nice but to weight for my netbook.
    I’ve tried a new instalation with xfce but the screen stays blank.
    If there is a problem with lightdm, can I use another session starter? which one? how I do it?

  • @jhoeD Of course! There are a bunch of them.

    Try lxdm, is not heavy and not that ugly.

    You also have slim, mdm, sddm, kdm…

    Cheers!

  • @karasu

    Slim has been abandoned for a while, I wouldn’t recommend using it.

    https://wiki.archlinux.org/index.php/SLiM

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • the problem I gues is after the instalation first boot I dont have the .xinitrc file in my home. what can I do? this file is not in the live usb neither.

blank screen10 Posts 15Views 4351
Log in to reply