• Text editor as File Manager


    Hi! I’ve been using Antergos for a few days. Have to say, I’m more than glad with it. It’s a less intimidating way of introducing Arch to the intermediate Linux user.
    However, I encountered a problem. I managed to configure everything, got the AUR repos working, and installed the software I used in my old distro, sublime text editor among others. I then noticed that when I opened any location from the “places” menu, sublime text is opened instead of nautilus.
    I googled about this, and found a possible solution involving editing of the mimeapps.list file. I found 2: one in .config/mimeapps.list and the other in .local/share/applications/mimeapps.list. Edited both adding
    inode/directory=nautilus-folder-handler.desktop;
    but did not work. I also tried removing sublime and reinstalling it, but also didn’t work.
    Any ideas? I searched the system with grep for the string “sublime”, but could not find any other list.
    Thanks!

  • The following line should be in ~/.config/mimeapps.list

    inode/directory=nautilus.desktop
    

    You’ll probably need to reboot for it to take effect. Let me know if it works okay for you. Cheers!

  • I tried it and even after a reboot, it didn’t work :persevere:

  • Hi

    Had this problem a while ago. Possible solutions:

    Do you have Audacious installed? If yes, try removing it:
    http://forum.antergos.com/topic/1323/how-to-set-nautilus-as-default-file-manager/2

    In earlier versions of Gnome Shell I think it could be caused when desktop icons are enabled. Go to Gnome Tweak Tool/Desktop and turn off ‘Icons on Desktop’

  • Hi Xler8, no, i don’t hace audacious installed and I switched on and then off again the icons on desktop option, still no change. While I figure this one out, I turned on icons on desktop, giving me quick graphical access to my home folder, and turned off the “places” menu. That almost does it for me, it’s just that I’m used to the places menu since Gnome 2.
    Thanks!

  • Have you checked what’s configured in Gnome System Settings. If memory serves me there’s a tab in the “System Info” module that allows you to set a few default apps. Though I also remember reading that they moved it to its own module. I could be making that up…not sure (i’m not a GNOME user lol).

  • Yeah, I checked. There is a default app section. It has a few settings but not for file manager…

    UPDATE: I solved it! After a deep research about MIME types and xdg-* commands, I did the following: (leaving the solution here as it was documented as an issue with other software)

    First, I ran

    $ xdg-mime default nautilus.desktop inode/directory

    which sets nautilus as default file browser, at least in theory. Then I ran

    $ xdg-mime query default inode/directory

    which returned

    nautilus.desktop

    And I thought that was it, until I tried it, and the text editor opened up again. After some more research, I checked the mimeapps.list in .local/share/applications/ and these lines were added with the first command from above:

    [Default Applications]
    inode/directory=nautilus.desktop

    What I had to do was check the mimeinfo.cache file, with similar syntax, it showed inode/directory=Sublime Text 2.desktop. After correcting it with nautilus.desktop, everything went fine. Hope someone else finds this useful! Thanks! Keep it up with Antergos, I’m loving it so far!

text editor1 nautilus17 mimeapps2 Posts 7Views 1285
Log in to reply