• Installing drivers for my wifi card

    I recently bought an MSI GS60 Ghost Pro, and promptly installed Antergos on the secondary hard drive as I have heard many good things and knew that I would need a linux environment for class.
    I have been unable to find out how to get my wifi working, but ethernet does work.
    The card in my laptop is a Qualcomm Atheros Killer N1525, and I haven’t been able to find any resources about making it work with linux.

    This isn’t just a problem with Antergos, after doing some research I found that I was not alone in trying to get wifi working.
    I’m having many of the same problems outlined in the linked post on the Ubuntu forums. I did a fresh install of Windows recently too, and noticed that neither LAN nor WLAN worked without me downloading the drivers on another computer, transferring them across to the laptop and installing them. The Windows drivers can be downloaded here, and are the Bigfoot LAN and WLAN driver on that page. It should be noted that I am actually able to use LAN through the ethernet port, but no wifi.

    How should I go about fixing this? Is it just something that will take time and I’ll need to wait for, or is there something I can do to get the wifi working?

  • @illikis said:

    Atheros Killer N1525

    It appears that this card will be supported by a new driver that hasn’t made it into the linux kernel yet. You might be able to build it yourself if you are so inclined: https://wireless.wiki.kernel.org/en/users/drivers/ath10k/configuration


  • @lots.0.logs Thanks for the quick reply!
    I don’t think I have the know-how to build it myself, so I’ll be waiting patiently for it to find its way to the linux kernel.

  • @illikis I had faced a similar issue before when I first installed Arch.
    The wired internet was working but the wifi wasn’t. I installed some random drivers I saw on arch wiki and even tried wicd instead of the default network-manager app. They didn’t help.
    You can try using wicd for yourself.

    But then one day I accidently removed EVERYTHING off my laptop. (All softwares, and the whole Gnome DE) then after installing it back, I noticed the wifi was working! So maybe our problem is same, maybe the drivers were not configured properly.

    Was your wifi working in the live iso?
    You may try the live session of ubuntu or fedora to check if wifi works in there…

  • @Yash No, I’m afraid in this case its not a configuration issue. His card is one of the latest cards released under that brand. The kernel does not support it yet. It shouldnt be long until support is added though.

  • @lots-0-logs so I came back to antergos after not using it for quite a while, and I was really hoping that this would have been integrated into the linux kernel by now, but my laptop doesn’t seem to support wifi, only ethernet. Do you have any suggestions on how I can get this working? Still the same situation as in the first post. I’ve done a fair amount of googling around but couldn’t really figure anything out and was hoping maybe you could help. Is there a package I have to install? What should I do?

  • @illikis said:

    Qualcomm Atheros Killer N1525

    Hmmm…try downloading the three directories shown here:


    Copy them into /usr/lib/firmware/ath10k and the restart your system. If it doesnt work please post the system logs here. Thanks.

  • @lots-0-logs I finally managed to get it working, by first doing what you said, and then following what was said here in comment 10. After copying all the files over it didn’t initially work, but then I noticed the edit saying to create a file and put some text in it, and when I restarted after that it worked. Thanks so much for the help!

wifi151 qualcomm2 atheros2 killer1 n15251 Posts 9Views 4582
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.