• Minimal install does nothing after network establishes


    I’m trying to install antergos with the minimal install and after it boots up, I am greeted with a notification stating that I need to connect to the internet.
    If I click on the network from the applet I am not asked for a password. I have to manually edit the network and put the password under network security tab.

    Then, it says it’s connected to the network. And nothing else happens.

    I went to another vt (ctrl+alt+2) and logged in. Pinged google and checked that I indeed was connected.
    I then tried to manually run cnchi from there with export DISPLAY=:0; cnchi only to be greeted at the desktop by a notice that cnchi needs root priviledge. I then tried the same after becoming root, but this time the x server doesn’t let cnchi to run on the desktop at DISPLAY=:0

    Any idea how to solve this?

  • Hi, try this:

    1. Switch to alternate VT and log in as root.
    2. Run this command: killall python && rm /var/lib/pacman/db.lck
    3. Switch back to the openbox session.
    4. Ctrl + Alt + Backspace
  • @lots.0.logs Thanks, I’ll try that as soon as I get home this afternoon and post an update

  • @lots-0-logs : We could add lxterminal to that iso…

  • After killall python, rm /var/lib/pacman/db.lck (there was no file there) and ctrl+alt+backspace: cnchi updated itself and started up. Then, only after choosing the language I am greeted with the screen telling me the prerequisites for the install (disk space, etc) and the internet connection shows up in red and I can’t continue.

    Funny that the installer can update itself from the internet and later says that I’m not connected :satisfied:

  • @chikitulfo A fix for this is being pushed out to the mirrors as I type this. Cheers!

  • Great!
    Now I am able to follow all the installation process, chose openbox, and then firefox, extra fonts, and something else I can’t remember. Then, after 45 minutes downloading 725 packages, it finishes downloading and says something along the lines: “Cnchi cannot install the selected packages. The installation can not continue.”

    This starts to feel like too much hassle to install a distro that claims to be for everyone…

  • @chikitulfo Because of the nature of a rolling release there are certain things that are beyond our control. It sounds like you may have a downloaded a corrupted package from one of the mirrors. If you could post the installer log, I’ll be able to determine exactly what went wrong. The log is located in the /tmp directory of the live environment and also should be copied into your installed partition inside /var/log

  • Uhm, I had to reboot to be able to post this, can’t grab it from /tmp, and /var/log is empty in the partition where it was being installed. There’s 800MiB worth of packages inside pacman’s cache though…

  • @chikitulfo Okay, try copying the package cache directory onto a separate USB drive (if you have one, its preferable). If you dont have one you can just try copying it to the live system (which will use RAM so it may not have enough space).

    Switch to another VT using Ctrl + Alt + F2 and log in as root. Then…
    If you have a USB drive:

    mkdir /mnt/usb
    mkdir /mnt/antergos
    # Mount your USB Drive
    mount /dev/sdbX /mnt/usb
    # Mount your Antergos Root Partition
    mount /dev/sdaX /mnt/antergos
    # Copy the package cache
    cp -R /mnt/antergos/var/cache/pacman /mnt/usb
    # Unmount the antergos root
    umount /mnt/antergos
    # Bind mound package cache directory to the live environment
    mount -o bind /mnt/usb/pacman /var/cache/pacman
    

    Now switch back to the openbox session and restart it with Ctrl + Alt + Backspace

    Cnchi will use the packages instead of downloading them again :) Let me know if you have any trouble. Cheers!

  • @lots-0-logs I was finally able to install!
    I must say though, that I ditched the minimal install ISO and used the full live ISO this time. And in the end I let it download everything from scratch.
    I didn’t choose any extra package from the installer screen that lets you install extra software. So now I would like to install the extra fonts, What’s the package name?

    Thanks a million for all your help! :grin:

  • Glad to see this is resolved! :smile:

  • @chikitulfo It’s ttf-google-fonts

    Cheers!

Posts 13Views 3686
Log in to reply