• Laptop will not suspend when the lid is closed, while an external display is connected(only Gnome gives me this issue).


    I am told that this is “expected behavior”. I am sure this is a bug that is called “expected behavior” since Gnome is the ONLY desktop environment on any platform that thinks it’s a good idea for the computer to stay away when an external display is connected.

    I wanted systemd to manage suspend activities so I went to ** /etc/systemd/longind.conf** and un-commended the necessary things:

    [Login]
    #NAutoVTs=6
    #ReserveVT=6
    #KillUserProcesses=no
    #KillOnlyUsers=
    #KillExcludeUsers=root
    #InhibitDelayMaxSec=5
    #HandlePowerKey=poweroff
    HandleSuspendKey=suspend
    #HandleHibernateKey=hibernate
    HandleLidSwitch=suspend
    HandleLidSwitchDocked=suspend
    #PowerKeyIgnoreInhibited=no
    SuspendKeyIgnoreInhibited=yes
    #HibernateKeyIgnoreInhibited=no
    LidSwitchIgnoreInhibited=yes
    #IdleAction=ignore
    #IdleActionSec=30min
    #RuntimeDirectorySize=10%
    #RemoveIPC=yes

    This isn’t working however and I think the reason is because Gnome settings are overriding the sytemd settings.
    In Gnome 3.14 I could go to org.gnome.settings-daemon.plugins.power with the configuration-editor app. but in Gnome 3.16 that path(org.gnome.settings-daemon.plugins.power) is no longer valid. I cannot even find anything related to power in dconfig-editor.

    Telling Gnome to suspend in the settings menu doesn’t work either.

    Any advice on how to solve this would be greatly appreciated.

    Thanks in advance

  • had the same problem both with an external display connected and without. switching from lightdm to gdm fixed the problem for me. ymmv

  • @William-Osendott Hmmm, it didn’t work for me unforunately 😕 At with gdm it now logs out when I put the laptop to sleep with terminal commands or screen timeouts, etc.

  • I’m not sure I understand. It completely logs you out, the same as if you restarted the laptop? When I put my laptop to sleep, and the wake it up, I just have to hit enter or click and drag upward, and then type my password (lock screen). It looks like the login-screen, but it’s not.

gnome304 suspend42 docked2 Posts 4Views 1826
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.