• [SOLVED]Problem with installation. *ERROR* Invalid PCC GPIO: 13! on first boot

    Hello everyone. I just installed Antergos for the first time and was very pleased with how painless everything was going until the installation finished and upon rebooting I was left with this error message.

    • [drm:ci_dpm_init [radeon]] ERROR Invalid PCC GPIO: 13!

    Fresh Gnome install from USB. Worked fine in the live environment and the installation went smoothly. I got the “Restart now?” prompt and after selection Antergos from the bootloader I was left with that dialogue.

    My graphics card is an R9 - 295x2.

    I really have no idea where to even begin with this, so any help would be appreciated.

  • @Herdo
    To begin with, is both a kernel 3.19.x and radeon driver issue.
    Reboot and choose Advanced from boot menu then Antergos Fallback (something like safe-mode Windows).

    Dont’ know, but replacing radeon (free) with catalyst (amd, proprietary) module may solve your problem.

  • @Herdo said:

    drm:ci_dpm_init [radeon]] ERROR Invalid PCC GPIO: 13

    Try adding this to the kernel boot command (Press e when grub appears):


    FYI: The kernel boot command starts off like this:

    linux	/vmlinuz-linux root=UUID=...
  • Thank you both. lots.0.logs, adding that stops the error, however it’s still not booting into Gnome. I was getting an error:

    • kvm: disabled by bios

    I enabled virtualization in my BIOS which got rid of that error, but now when I reboot it just sits at:

    • Starting version 219.
  • We will need to see the logs (journal, xorg, and lightdm). See the HOW TO sticky post for instructions. You can switch to another VT using Ctrl + Alt + F2

  • I reinstalled and it booted just fine this time. It seems to be kinda buggy though. Certain applications fail to launch (Add/Remove Software and the Update Manager). Very strange.

    Here is the archive of my log files. The x-0-greeter.log file did not exist but a x-1-greeter.log did so I’ve included that.


    EDIT: Found the x-sessions logs, sorry about that. I’ve updated the logs.tar

  • Ok I reninstalled and now the Add/Remove Software and the Update Manager applications are working. Music and Screen Reader are not however (they also don’t work in the live environment).

    Not a huge deal considering I don’t use either of those right now. Thank you for the help!

  • Hi,

    Glad you sort of solved it 😬

    By the way, gnome-music was a bit buggy the last time I tried (with 3.14) We include it as we want to give a Gnome feeling to all the DE but feel free to use another music app, of course.


  • Ah, thank you for the reply karasu. I USB booted Manjaro Gnome and the music player failed to open so it’s definitely not a problem with Antergos.

    Everything else is working good so far!

  • For Gnome-Music, try to open Totem (Videos) first, close it and then open Music again.

  • Haha, it worked! Thank you roberto. Any idea why this works?

  • Haha, it worked! Thank you roberto. Any idea why this works?

    Maybe gnome-music fails to init GStreamer and totem does it for it, some kind of bug must be there. But I’m only guessing.


  • @karasu It worked in so far as opening the program but failed to find any of my Music (which is in the default location) and promptly crashed when I clicked on its “Help” option. Ironic indeed :-)

  • Huh, very strange.

    @siabost9deas I actually solved this issue I think before I solved the issue of the Music application not opening.

    You mentioned your music being in the default location. You may already know this, but if you mean simply within your ~/Music folder, you may need to set that as the default music location in ~/.config/user-dirs.dirs (I had to).

    I believe XDG_MUSIC_DIR="$HOME/Music" will do it.

    If that fails, this post may be of some use to you.

  • @Herdo Thanks.
    Since my post I’ve reinstalled Antergos-Gnome using the latest ISO as I fancied the Update Notifications feature and I was running out of space on my SSD anyway. This time I’ve gone LVM.
    After the reinstall Gnome-Music finds my music just fine and the correct default music location is listed in ~/.config/user-dirs.dirs as per your post.
    If I could now find out why Cheese strikes up a GStreamer error on launch, all would be good :-)

Posts 15Views 5249
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.