• UEFI bootloader installation fails


    Hey there,
    I am trying to install Antergos on a GPT UEFI system using automatic partitioning and standard settings. In the end it says (translated to English) “there may have been problems during the bootloader installation”.
    I already tried this with all combinations of GRUB2 or gummiboot and encryption enabled or disabled. Cnchi is version 0.8.29
    I hope you can help.

    PS: I would attach logs but uploads just fail with “413 Request Entity Too Large”.
    EDIT: now uploaded them to my webhoster: http://yel-o.de/logs.tar

  • Hi, actually the installer log is located in the /tmp directory of the live environment. There’s nothing from the installer that is sent to the regular system journal.

  • @lots.0.logs I could see some interesting things in the journal, anyways, I now packed the cnchi.log too. Just redownload the logs.tar.

  • Give this a try and let me know the result please:

    After the installer is auto-updated, close it and run the following commands:

    su
    cd /usr/share
    rm -rf cnchi
    git clone http://github.com/antergos/cnchi.git cnchi
    exit
    sudo -E cnchi -dv
    
  • Didn’t work either, I updated the logs.

  • Just to confirm…You are rebooting between attempts right?

  • Have you tried selecting Grub as the bootloader with the latest version available on github?

  • Nope didn’t work either, no trying without encryption and grabbing the logs

    Didn’t work either without encryption… Logs are here: http://yel-o.de/cnchi.log
    I figured out I wouldn’t need to pack it as it’s only one log.
    Do you need any other files?

  • I will now try with LVM

  • This post is deleted!
  • I use autoformatting which should handle things correctly (?)

  • Actually, forget what I said in my last post…sorry! I’m pushing out v0.8.48 right now. Please let me know how it works for you. Thanks.

  • I had the same problem and with v0.8.48 it worked! 😉

  • Did work once with grub2 and without lvm or encrytion. Otherwise somehow failed. I’m afraid I have to setup a production-ready system without UEFI now and can’t test anymore. If you haven’t I will test all combinations when I have time (next weekend).

  • @petabyteboy No worries. Thanks so much for reporting your results to us!

  • So is it working already? UEFI installation with gummiboot?

  • In our testing bootloader installation is working with gummiboot and grub. Please let us know if you have any trouble with it.

Posts 18Views 3071
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.