• \[Solved\] LightDM does not start automatically


    Hi there
    I’ve installed Antergos with OpenBox. Then I installed LightDM und uninstalled SLIM but LightDM is not starting automatically so I have only console login.

    What can I do?

    Best regards, Happy

  • Hi there
    I’ve installed Antergos with OpenBox. Then I installed LightDM und uninstalled SLIM but LightDM is not starting automatically so I have only console login.

    What can I do?

    Best regards, Happy

  • Hi,

    you have to enable light-dm.

    try:

    sudo systemctl enable lightdm.service  
    
    
  • Hi,

    I’ve executed:

    sudo systemctl enable lightdm.service
    

    The following error was shown:

    Failed to issue method call: file exists
    

    I found the file “lightdm.service” in “/usr/lib/systemd/system”.

    EDIT:
    Content of /usr/lib/systemd/system/lightdm.service:

      
    [Unit]  
    Description=Light Display Manager  
    Documentation=man:lightdm(1)  
    After=systemd-user-sessions.service  
      
    [Service]  
    ExecStart=/usr/bin/lightdm  
    StandardOutput=syslog  
    Restart=always  
    IgnoreSIGPIPE=no  
    BusName=org.freedesktop.DisplayManager  
      
    [Install]  
    Alias=display-manager.service  
      
    
    

    Best regards, Happy

  • The problem was that you removed the slim package without disabling the service first, so there’s a symbolic link that remained in your system.

    To solved it do this:

    sudo unlink /etc/systemd/system/display-manager.service
    

    And then enable lightdm as usual

    sudo systemctl enable lightdm
    
  • Hi faidoc,

    problem solved, thank you very much

    Best regards, Happy

Posts 6Views 3901
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.