• Live USB resolution problem


    I was trying to install antergos onto my desktop and the resolution was really low (probably 1024x768 or less) while on my laptop that has an older bios the live usb boots up perfectly without any resolution issues, any idea on whats happening? Also the specs for my desktop is an amd fx 8350 and a gtx 750 ti and the mobo im using does not have onboard graphics.

  • Hi,

    Currently the open source driver for NVIDIA cards does not support accelerated graphics with the latest generation of cards released by NVIDIA. The GTX750 falls into that set. Until the nouveau maintainers can get the information they need (from NVIDIA) to implement full support for accelerated graphics, you may be better off using the proprietary driver on your installed system.

  • @lots.0.logs ok so I can just install and after installing install the proprietary driver? Thanks for the help!

  • Yes, that’s correct :)

  • @lots.0.logs So I was busy this week and just now was able to install antergos. now how do I install the nvidia proprietary drivers?

  • Hi,

    You can install them with this command (answer “Y” when prompted/warned about removing conflicts):

    sudo pacman -S nvidia nvidia-utils nvidia-libgl 
    

    Don’t forget to reboot your system after installing the packages. Let us know if you have any trouble!

  • @lots.0.logs I installed it and it works perfectly, thanks! on an unrelated note, I can’t get steam working. When I run steam in the terminal I get:
    /etc/lsb-release: line 4: Linux: command not found
    /etc/lsb-release: line 4: Linux: command not found
    /etc/lsb-release: line 4: Linux: command not found
    /etc/lsb-release: line 4: Linux: command not found
    Running Steam on arch 2015.04-ISO-Rolling 64-bit
    /etc/lsb-release: line 4: Linux: command not found
    /etc/lsb-release: line 4: Linux: command not found
    STEAM_RUNTIME is enabled automatically
    Installing breakpad exception handler for appid(steam)/version(0_client)
    libGL error: unable to load driver: swrast_dri.so
    libGL error: failed to load driver: swrast

  • @Tom-G said:

    @lots.0.logs I installed it and it works perfectly, thanks! on an unrelated note, I can’t get steam working. When I run steam in the terminal I get:
    /etc/lsb-release: line 4: Linux: command not found
    /etc/lsb-release: line 4: Linux: command not found
    /etc/lsb-release: line 4: Linux: command not found
    /etc/lsb-release: line 4: Linux: command not found
    Running Steam on arch 2015.04-ISO-Rolling 64-bit
    /etc/lsb-release: line 4: Linux: command not found
    /etc/lsb-release: line 4: Linux: command not found
    STEAM_RUNTIME is enabled automatically
    Installing breakpad exception handler for appid(steam)/version(0_client)
    libGL error: unable to load driver: swrast_dri.so
    libGL error: failed to load driver: swrast

    Ok so after a bit of searching on the forums this link helped me: http://forum.antergos.com/topic/1906/solved-running-steam-spits-out-a-failed-to-load-driver-swrast-message-know-a-fix
    Thanks for the help with antergos, this was my first time using a arch linux distro after using ubuntu for over a year. Again thanks for the help!

Posts 8Views 2026
Log in to reply