• [SOLVED] Fresh OS: No user directory


    Hello,
    I installed antergos with kde, but I can`t login. I see the light DM… the password Is correct, but the screen becomes black and return on the lighDM.

    I try to use tty2 but it says “j03: /home/j03: change directory failed: No such file or directory

    Obviously I can’t use startx, it say: "error in locking authority file"
    I can’t copy the files from /etc/skel as the directoryIs empty.

    Thanks

  • I have resolved in this way, after ctrl + alt + f2:

    # cd /home
    # mkdir UserName
    # chown -r UserName:users
    # xdg-user-dirs
    

    Than I downloaded the kde-setup from github.

  • @J03Bukowski Did you install home in a different partition than root?

  • Hi.
    I’m following this topic because I’m haveing the same problem also with a fresh openbox install and I installed the /home in dev/sda6 and ‘/’ on dev/sda3. My system showed me the same error,. I will try another fresh install again tomorrow. I was happy because the grub & lightdm error was solved, but we are always learnin. I hope we can learn something else whit this new issue.
    Best regards!

  • @karasu yes, I installed the “/” and the “/home” in two different partitions

  • @eliko: I think @lots.0.logs has not given permission to our build server to rebuild the Cnchi package to the latest version (the one that includes the /home fix). We wanted to do more tests first. To check it, Cnchi should be at least 0.8.39 (anything older than that will have the bug).

    Cheers!

  • Thank you very much for your answer @karasu.
    Let me tell you that today I tried to install again with the new Cnchi 0.8.48, but now I had problems with Lightdm again. I share my Cnchi log and Lightdm log.

    Cnchi log

    Lightdm log

    Maybe you understand what is happening now.

    Cheers!!

  • I see the problem. (a typo :grimacing: ) here comes 0.8.49…

  • Thanks a lot @lots-0-logs!!
    I will install right now again!!
    I’ll share how it works.

    Thumbs up!

  • Hello @lots-0-logs and @karasu, again, thanks for your help and efforts building antergos. Last night I did a fresh install again with Cnchi 0.8.56 and I had the white screen instead of lightdm screen. My logs again [I upload the .tar file on an external service, I wasn’t able to upload it here]
    logs

    Cheers!

  • @eliko Are you installing in Virtualbox? There is a bug in Virtualbox right now that prevents the Lightdm greeter from functioning. The only work-around is to switch greeters.

  • @lots.0.logs so far since the bootloader issue was fixed I’ve downloaded the following in Virtualbox with absolutely no issues:

    Gnome
    Openbox
    Mate
    Cinnamon

    I did experience issues with KDE

    Haven’t tried XFCE yet

  • @jaws222 Wow! Thanks for testing all those!

    We had an issue in KDE with the kcalc package (it was renamed). It’s fixed now.

    Again, thanks!

  • @lots.0.logs No. I’m installing on my netbook.
    Thanks again.

Posts 14Views 2925
Log in to reply