• Uknown display when connection second screen

    Since a short time antergos doesn’t recognise my external displays anymore. I have connected 5 different screens but all of them is saying “unknown display”. The big problem is i can’t select any resolution higher then 1024x768. This is very annoying. I think 2 or 3 weeks ago everything just worked fine but now i have this problem with all kind of screens (but not my laptop screen). Xrandr give me exact the same output. Even when i add manual a resolution to the VGA1 port i can’t switch to it. The screen turns black for a moment and then it’s exactly the same old resolution.
    Can someone help me further with this? I really don’t know what to do.

  • Hi,

    It sounds like a kernel bug. Try installing the LTS kernel, boot with it, and see if the problem persists.

    sudo pacman -S linux-lts
    sudo grub-mkconfig -o /boot/grub/grub.cfg
  • Hi,

    Still doesn’t work. And i have 2 other problems now: booting is slower and my laptop can’t suspend anymore.

  • What’s the output of: lspci -k | grep -A 2 -E "(VGA|3D)"

  • lspci -k | grep -A 2 -E "(VGA|3D)"
    00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
    Subsystem: Hewlett-Packard Company Device 30db
    Kernel driver in use: i915

    My graphics card is a Mobile Intel GMA 4500MHD (really old one )

  • Try configuring it to use UXA instead of SNA as outlined here:


  • I did but still not working :(.
    I added a own resolution to the VGA1 port (full hd) and it’s working. I have a full hd output on my vga port and i see it on my monitor, but… the colors are awfull. I just don’t understand why my screens aren’t detected suddenly.

  • It is very strange. If they suddenly stopped working that would mean its something to do with a kernel update. However, that should also mean that the LTS kernel would not have the same issue. Please post your logs here and I’ll take a look. Thanks.

  • I think the problem is worser then i though… I’ve tried a live antergos usb but the same problem: the screen is still not recognised. Also on a elementary and lubuntu live usb… I think this is a hardware issue :(.

  • When i’m searching around the web i see more users (windows) have had the same problem with an external monitor… And nobody really had a solution.
    A little question, how can i switch back to the old kernel? Because this one is slower and my laptop can’t suspend anymore.

  • All you have to do is select the other kernel from the grub menu at boot.

display39 screen17 xrandr3 uknown1 Posts 12Views 3386
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.