• BUG: Unable to lock/autolock Antergos Gnome on Alienware m11x r2


    Hello awesome Antergos Community,

    before I post about my issue, I just want to express to the devs how much I love this distro. Honestly, I fell in love with Antergos from the moment I booted it as a live ISO. Your live USB, which in all other distros is usually mind-numbingly slow is faster then Ubuntu Gnome installed on my hard drive! Esthetics wise, it is also one of the most beautiful distros I’ve seen. Like all distros, Antergos has its problems but you’ve put alot of love into it.

    My issue:

    I’m not being able to lock Antergos, neither manaually or autolock.

    **My setup: **

    Antergos gnome. Installed on a Alienware m11x r2 + Kingston SSD now V300 (240GB) - 8gb RAM. /boot, / and /home are three different partitions. The is no swap… /boot is un-encrypted ext2. / and /home are LVM2 volumes embedded within a LUKS container. If you need more detailed info or logs, please let me know.

    What I’ve tried: setting auto lock to turn on in 5 minutes after display off, immediatetly after display off - failure. Ctrl-alt-L (typical) command to lock - failure. Suspend - doesn’t lock on wake. The lock icon in the top right corner of screen causes my computer to power down unsafely instead of lock.

    Do you have any recommendation?

    I have some other issues but will be posting about it seperately.

  • So, I opened a terminal and tried:

    dm-tool lock

    and I tried it with one of hans zimmer’s more epic sound tracks playing in the background for effect. The screen turned off but the music was still playing. So the screen was locked! When I pressed on the keyboard, the screen stayed blank. Same with the mouse buttons and the power key. Nothing was waking it up. The same thing happened when I pressed the lock button in the top right corner. The only thing I could do was turn off the PC and reboot.

    The strange thing about all of this is that I’m getting a lock screen when I log into Antergos, so this shouldn’t be happening.

  • Same problem but I’ve managed to go back to antergos pressing Ctrl + alt + f1

    P.S. In another PC using the testing build it seems to work fine.

  • Full and complete screen locking is currently not possible without switching to GDM. We’re working on a permanent solution. In the meantime if having your screen locked is important (and simply displaying the greeter won’t be enough to deter threats) then we recommend that you install GDM:

    sudo pacman -Rcc lightdm
    sudo pacman -S gdm
    sudo systemctl -f enable gdm
    
  • Thanks for the answer. I’ll install GDM. I have LUKS encryption. Does that have any compatibility issues with either GDM or lightDM?

  • No, by the time the display manager is started you have already unlocked your encryption.

    Cheers!

  • Thanks again!

  • So I’ve tried GDM for a few days. It’s a good temporary replacement for lightDM but Antergos is nowhere near as snappy as it is on LightDM. Would it be possible to give us a heads up on this thread when the conflict has been resolved so that I can switch back to it? I’d really appreciate it.

  • @Fadi-R Actually, this will be resolved very soon. I’ll publish a blog post about it in the next couple days. Cheers!

  • I can’t wait!!! :)

  • @lots.0.logs I tried to look through the forum for the announcement you mentioned but I wasn’t able to spot anything. Do you have a link for it. Does going back to light DM involve anything more then say:
    systemctl -f disable gdm
    systemctl -f enable lightgdm

  • @Fadi-R For an existing installation you would have to do this:

    su
    pacman -S lightdm light-locker light-locker-settings xscreensaver gnome-shell-extension-status-menu-buttons
    systemctl disable gdm
    systemctl enable lightdm
    rm /etc/xdg/autostart/xscreensaver.desktop
    gsettings set org.gnome.desktop.screensaver lock-enabled false
    gsettings set org.gnome.desktop.session idle-delay 0
    sed -i 's|echo "X|/usr/bin/light-locker \&\nsleep 3; echo "X|g' ${DESTDIR}/etc/lightdm/Xsession
    

    Next, create this file: ~/.xscreensaver and add this in it:

    newLoginCommand: light-locker-command -l
    timeout: 0:10:00
    fade: True
    unfade: False
    fadeSeconds: 0:00:03
    fadeTicks: 20
    dpmsEnabled: True
    dpmsStandby: 0:10:10
    dpmsSuspend: 0:30:00
    dpmsOff: 4:00:00
    

    Finally, configure your preferred settings using the light-locker-settings application.

    Let me know if it works okay for you. Cheers!

  • Awh, man, you rock! I’ve just ditched GDM. (sigh of releif…) I’ll give your fix a go! Let you know how it goes.

  • I’m assuming the ~/.screensaver is for the main user account that I’m using to log in and not the root account. Am I correct?

  • light-locker-settings was not starting up. When I tried to run it from terminal, it gave the following output before terminating:

    light-locker-settings error output Pastebin

  • This post is deleted!
  • I see why you choose the handle lots.o.logs… :)

  • Thanks. I thought I fixed that error, but maybe I forgot to update the package. I’ll check it out. Be on the lookout for an update to the package soon. Cheers!

  • Thanks! BTW, will it also support locking when the display turns off as well?

  • Man, lightDM is the beesknees!! I love it!

lock22 autolock1 powermanagement11 management4 power10 Posts 28Views 7333
Log in to reply