• [Solved] Multilibs Needed?

    I am still a noob to arch and antergos so have much yet to learn. That said, I have been told by someone that I need to edit pacman.conf file to enable multilibs. Is this true and, if so, is there a basic tutorial I can follow? Thanks. :-)

  • Open terminal
    Type “sudo nano /etc/pacman.conf” without quotations
    Scroll down till you see “#[multilib]”, and a url under it.
    Remove the # signs from both lines, and resync in terminal with -Syy.
    Save by pressing ctrl + x and hitting y.

  • i dont think its needed unless you are missing packages?

    example i think wine is in the multlibs. so i enabled it for that.

    its pretty easy.
    sudo typeyourtexteditorhere /etc/pacman.conf

    look for this section and uncomment out multilibs like so

    Include = /etc/pacman.d/mirrorlist

    Include = /etc/pacman.d/mirrorlist

    #Include = /etc/pacman.d/mirrorlist

    Include = /etc/pacman.d/mirrorlist

    If you want to run 32 bit applications on your x86_64 system,

    enable the multilib repositories as required here.

    #Include = /etc/pacman.d/mirrorlist

    Include = /etc/pacman.d/mirrorlist

    refresh your database and update.

  • I see, that’s easy enough. Uncomment the "testing line too then? Thanks y’all! :-)

  • @Mike-Smith After you update you also need this:
    Multilib repository
    First, enable the Multilib repository as described in Multilib. Then install the gcc-multilib package.
    I suggest you learn to check the Arch Wiki for info on such things, it is excellent. https://wiki.archlinux.org/index.php/64-bit_FAQ

  • @Mike-Smith

    Please, NEVER uncomment testing or multilib-testing. That’s only for developers and package maintainers. You can end with a broken system if you enable those.


Posts 6Views 2948
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.